FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


I'm having problem htaccess





airh3ad
Guys can anyone check my account i'm having problem updating htaccess . i tried to change settings in wordpress permalink the error is update your htaccess i already change the mod to 755 so it can write or 666 just to make sure it will be updated but same error.
Peterssidan
Does it say what content to put in the .htaccess file so that you can do it manually? Note that the .htaccess filename starts with a dot.
deanhills
airh3ad wrote:
Guys can anyone check my account i'm having problem updating htaccess . i tried to change settings in wordpress permalink the error is update your htaccess i already change the mod to 755 so it can write or 666 just to make sure it will be updated but same error.
Hi airh3ad.

I checked .htaccess and you did do it correct. This is a WordPress problem and with the little I Googled it looks as though many people have the same problem as you have. Suggest you check in with Word Press support forum and ask their help.
https://wordpress.org/support/forum/how-to-and-troubleshooting

Tip from my side would be for you to go back into your WordPress Dashboard, resave the permalinks as they are. Then make the change and see whether it takes this time round. Try it a few times.
airh3ad
Hi Deanhills i try many times to save the permalinks, thanks anyway i will just find ways to solve this case. wordpress support also having a problem this case.
deanhills
@airh3ad

I'm just wondering whether if you added your domain name to the RewriteBase/ whether that may work? Can you try it?

Quote:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress


Code:
RewriteBase /easternsamar.net


If the above doesn't work, have you thought about checking plugins that could help with the permalinks? There are a few available depending on what you want. I would be cautious however and only use up to date 5-star ones that have recent support (check how it is supported and the problems people get when they use the plugin before you choose the plugin):

https://wordpress.org/plugins/search.php?q=permalinks
airh3ad
Hi deanhills,

i try your advise but same thing 404 error. any other way we can solve the problem? wordpress support also advise me to check with my host.

Quote:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /lapulapucebu.com
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
deanhills
airh3ad wrote:
wordpress support also advise me to check with my host.
I noticed that too. Wink

Thing is if you read the literature quite a number of hosts have that feature hidden or disabled for security reasons.

I'll keep my eyes open for solutions. I'm sure there must be a few.
deanhills
OK airh3ad. After lots of research I found the following solution - I also made a small tweak in one of the core files:

1. Delete the .htaccess file (I renamed it for now - but if this solution works can you please delete the .htaccess file).

2. OK now go into your Word Press Dashboard permalinks and click on the default button and save the default settings. So now you have the default permalink settings enabled.

3. Then go back in the permalinks and choose the settings you want. Save it and see whether it works this time round.

Let me know if it worked. If not, I'll set everything back to what it was before.
airh3ad
Hi Denhills,

Still the same error. in wordpress this is the error. You should update your .htaccess now.

Quote:
Not Found

The requested URL /contact-us/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2 Server at www.lapulapucebu.com Port 80


Any advise

thanks
jajarvin
.htaccess Generator can help you if
you have .htaccess-problems.
deanhills
airh3ad wrote:


Any advise

thanks


OK. Try this solution. Don't change anything (keep the .htaccess still disabled). But add /index.php/ in front of the custom permalink tag.

Quote:
How to work with servers that don’t use Apache mod_rewrite

Using permalink structures requires that your web hosting provider has a specific Apache module option — mod_rewrite — activated on its servers. If your web hosting provider doesn’t have this option activated on its servers or if you’re hosting your site on a Windows server, the custom permalinks work only if you type /index.php in front of any custom permalink tags.

For example, create the custom permalink tags like this:

/index.php/%year%/%month%/%date%/%postname%/

This format creates a permalink like this:

http://yourdomain.com/index.php/2008/02/01/wordpress-for-dummies

You don’t need an .htaccess file to use this permalink structure.

Source: http://www.dummies.com/how-to/content/how-to-ensure-your-wordpress-permalinks-work-with-.html
airh3ad
Your the man deanhills , my permalinks on my site is now working. great job.Smile
deanhills
airh3ad wrote:
Your the man deanhills , my permalinks on my site is now working. great job.Smile


Finally! How to sort out pesky WordPress Permalinks without fiddling with risky .htaccess and server configuration. Mission accomplished!
Related topics
How do we install Invision Board manually through cpanel?
Web2Messenger Invite
the simple guestbook
Winzip, winrar...
problem with my computer
Can't enter my Gmail Account! Help and I send you invatation
Can't restore database
Mambo Installation Help. Problem with the "path"
Problem with using Dev-C++ Editor
Computer network job
Mod_Rewrite trouble
I know everyone does have problem with pimples
Problem playing NFS
I am having problem again...
Domain Controller problem
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.