FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


PHP Version in Server 2





FunDa
I was trying to install a PHP analytics software called piwik and was trying to install it.

In the install page, it said that the PHP version has to be atleast PHP 5.3.3 or higher. Otherwise the installation cannot proceed.


Crying or Very sad

It said "Unfortunately it seems your webserver is using PHP version 5.2.17."


I was wondering if I can upgrade PHP version to 5.3.3 ?

Any ideas ?

Another tip said

If your web host supports PHP4 but hasn’t enabled PHP5, it might be possible to enable it manually. Here are the most common ways to enable PHP5; create a .htaccess file in your piwik folder containing

version A: AddHandler php5-cgi .php
or version B: SetEnv PHP_VER 5
or version C: AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php



But this didn't seem to work ..
deanhills
FunDa wrote:
I was trying to install a PHP analytics software called piwik and was trying to install it.

In the install page, it said that the PHP version has to be atleast PHP 5.3.3 or higher. Otherwise the installation cannot proceed.


Crying or Very sad

It said "Unfortunately it seems your webserver is using PHP version 5.2.17."


I was wondering if I can upgrade PHP version to 5.3.3 ?

Any ideas ?

Another tip said

If your web host supports PHP4 but hasn’t enabled PHP5, it might be possible to enable it manually. Here are the most common ways to enable PHP5; create a .htaccess file in your piwik folder containing

version A: AddHandler php5-cgi .php
or version B: SetEnv PHP_VER 5
or version C: AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php



But this didn't seem to work ..
Hi FunDa. Nice to see you posting after all of this time. Very Happy

I think Bondings is the only one who can fix this. Quite a number of other users have tried different ways, but the php version needs to be upgraded on the Server. It would be interesting if a work around could be found, but have a feeling maybe not.

Would be nice if Bondings could upgrade php such that different versions of php could be used. There is a way to set the server up for ability to use previous versions.
https://features.cpanel.net/topic/allow-to-install-multiple-php-5x-versions
FunDa
Thanks. Was busy for a couple of years Laughing

I managed to get another web analytics software working called Open Web Analytics, but it's not as good as Piwik is supposed to be.

And of course, PHP has to be updated anyway. I think some problems I have with upgrading Wordpress may also be related to the PHP being old.

I'm back in the game. See you around.
Related topics
Tutorial: PHP Installed Modules Dynamic Reference Tool
php without server
PHP DB Error: syntax error
What are the versions of PhP and MySQL on this server...
PHP version 5.0
Enabled PHP Methods
Which PHP version?
PHP Version
Tradewar PHP version
php version
new php version
version del php?
Which php version on the new server? (5.2.12 or 5.3.1)
php version?
PHP version on Server 2/3 [Suggestion]
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.