FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Wordpress and plugins





truespeed
I know I won't get an answer for this,but,have plugins and themes been disabled for wordpress?

I installed wordpress on a new site just now,and the only files that won't load are themes.php and plugins.php.

The only explanation I can think of is they were disabled?
deanhills
I can't see how they would have been disabled as if they had there would have been a huge number of complaints. My guess is that it may be the particular theme and plugins you're trying to load that are either in conflict with what you already installed, or on a different version of php. Best way to check may be to create a dummy sub-domain or add on domain, load WP fresh and then see whether the theme works.
RosenCruz
I had problems with Akismet in the past, and that is why I moved my main domain away from frih servers.
dude_xyx
Some php functions are disabled in servers so it might be the problem. I had problems with plugins in past so I stopped using Wordpress for sites I host here except for the main sub domain I received from Frihost.

You can just use another theme and see if it's a theme specific error or not.
RosenCruz
Quote:
You can just use another theme and see if it's a theme specific error or not.



Agreed. Doing another install will help you create a control group of the problem
deanhills
I'm on Server 1. I've been using plugins and themes successfully with WP. Not sure whether something may have happened after our move to a different server as haven't worked on my Website for a few weeks, but up till then I had been experimenting with all kinds of WP plugins and themes.

OK. Have just checked up on that Website (on Server 1) and I had the opportunity to update one of the plugins. Update went through without any problem.
Quote:
Update Plugin

Downloading update from https://downloads.wordpress.org/plugin/contact-form-7.3.9.zip

Unpacking the update…

Installing the latest version…

Removing the old version of the plugin…

Plugin updated successfully.
dude_xyx
I'm on server 2 and used to have hellwa lot of Wordpress related problem. Couldn't install JetPack and then I needed to install another plugin to do Wordpress upgrades. Dashboard was so slow too. But I think now it's better. Dashboard is not that slow. Also Jetpack is working now.
deanhills
I know the name servers aren't doing to well on Server 2 after the move, but wonder whether Word Press is easier to use in comparison with before the move as I've got a suspicion that Server 2 and Server 1 are now sharing the same space in Germany whereas before Server 2 had been in the US and Server 1 in Germany.
RosenCruz
I will try to upload 2 dot.tk WordPress sites on my FriH account. If only that good old FTP would allow Rolling Eyes
dude_xyx
deanhills wrote:
I know the name servers aren't doing to well on Server 2 after the move, but wonder whether Word Press is easier to use in comparison with before the move as I've got a suspicion that Server 2 and Server 1 are now sharing the same space in Germany whereas before Server 2 had been in the US and Server 1 in Germany.


Well apart from the nameserver problem I think location of sever 2 is better than old location. Also the configurations are better maybe or it's a faster server.
truespeed
I think I know why it wasn't working for me,a while ago I had a wordpress blog on here and Bondings got a dmca for one of the posts and took it offline,he sent me an awit asking me to remove the post,which I had to do via phpmyadmin as there was no access to wp-admin. I ended up just moving the site to my own host as Bondings wasn't around much and I didn't know for sure how long my site would be offline.

So I assume some setting that was changed hasn't been reversed. Smile

Anyhows,I have also moved my new site to my own hosting,I only tried moving it to frihost as I was having trouble with the nameservers,they are working now.
RosenCruz
Despite loading the files through FTP and trying on different domains, I can not install WP on my account.

I tried deleting and re-adding the domain, completely renewing files and checking permissions etc.

I can not skip to the secound installation step.

After I enter database and user details and everything, I get a browser error page 324 . Nothing spesific. Weird. Rolling Eyes[/b]
dude_xyx
Did you try accessing the site through a proxy ? Sometime it's a DNS problem at ISP provider or computer. It has happened to me several times. Happened me here too right after Bonding moved servers.
RosenCruz
dude_xyx wrote:
Did you try accessing the site through a proxy ? Sometime it's a DNS problem at ISP provider or computer. It has happened to me several times. Happened me here too right after Bonding moved servers.


I can see the welcome and we need a config.php pages. I can enter installation details and etc. I do not believe it is a DNS issue Question

I will browse via ZenMate and add here though
deanhills
RosenCruz wrote:


I can see the welcome and we need a config.php pages. I can enter installation details and etc. I do not believe it is a DNS issue Question

I will browse via ZenMate and add here though
Have you flushed your DNS a few times? Got rid of all of the cookies? Tried to do the installation from a different computer?
RosenCruz
deanhills wrote:
RosenCruz wrote:


I can see the welcome and we need a config.php pages. I can enter installation details and etc. I do not believe it is a DNS issue Question

I will browse via ZenMate and add here though
Have you flushed your DNS a few times? Got rid of all of the cookies? Tried to do the installation from a different computer?


Yeah I tried installation on a different browser / computer.

I believe the issue might be related to config.php / config.sample.php conversion

Will try to fix and update you guys
RosenCruz
Well here is the update,

I tried on fresh .tk domains too, all give the same error code 324 if I let WP edit the config-sample.php


--------------------

When I create config.php myself, I get
Code:
headers already sent error on config.php line 1
.

I believe this issues can be worked out, but I m so busy at the moment, so I will give up and host my little blogs elsewhere. They are mostly little informative non-commercial stuff. Catching up with my phD and running a few blogs at the same time can consume too much time

Crying or Very sad
deanhills
RosenCruz wrote:
Well here is the update,

I tried on fresh .tk domains too, all give the same error code 324 if I let WP edit the config-sample.php


--------------------

When I create config.php myself, I get
Code:
headers already sent error on config.php line 1
.

I believe this issues can be worked out, but I m so busy at the moment, so I will give up and host my little blogs elsewhere. They are mostly little informative non-commercial stuff. Catching up with my phD and running a few blogs at the same time can consume too much time

Crying or Very sad
I Googled the "error warning" and it came up with the following solution - not sure whether this could be applicable to your situation as well:


Quote:
Took me a month to find the solution but mine was in the wp-config file. There were two lines at the end of the code after the ?>. Once I deleted those all was fine.

I had to work my way through each error to find the files that were affected and there were a couple of lines where the code was not aligned with the hierarchy above it. Not sure whether "correcting" this made any difference, but it did not solve the problem completely until i did the above. GOOD LUCK - its a very frustrating error.


http://wordpress.org/support/topic/yet-another-warning-cannot-modify-header-information-topic
RosenCruz
Quote:

http://wordpress.org/support/topic/yet-another-warning-cannot-modify-header-information-topic


Thanks for bringing this link up. I will try it Dean Wink

I was kinda angry and frustrated and deleted whole domains and files. Now back to good old FTP Sad
deanhills
RosenCruz wrote:


I was kinda angry and frustrated and deleted whole domains and files. Now back to good old FTP Sad
I know that feeling. Razz
RosenCruz
Now I get this.

I did a fresh download latest WP. and I believe my config.php is clear and includes no empty lines. Weird

Rolling Eyes

Code:
Warning: Cannot modify header information - headers already sent by (output started at /home/rosencru/domains/ata-gdfghk.tk/public_html/wp-config.php:1) in /home/rosencru/domains/ata-turk.tk/public_html/wp-includes/pluggable.php on line 1121
deanhills
RosenCruz wrote:
Now I get this.

I did a fresh download latest WP. and I believe my config.php is clear and includes no empty lines. Weird

Rolling Eyes

Code:
Warning: Cannot modify header information - headers already sent by (output started at /home/rosencru/domains/ata-gdfghk.tk/public_html/wp-config.php:1) in /home/rosencru/domains/ata-turk.tk/public_html/wp-includes/pluggable.php on line 1121


I find this solution?
Quote:
If you get this error and dont have any spaces or line breaks in wp-config.php outside <?php and ?>, check that the wp-config.php is saved as utf-8 without BOM

Source: http://wordpress.org/support/topic/pluggablephp-on-line-1121

and
Quote:

Hi There!

1- Download wp-config.php from your server.
2- Open Notepad++ (really you don't have it?) open wp-config.php
At last of wp-config.php erase the code ;> if it writing there.
3- Go to menu Enconding and select 'Enconde in UTF-8 without BOM'.
4- Uploading wp-config.php to your server.

That's it.

Download Notepad++
http://notepad-plus-plus.org/download/v6.5.5.html

Information about Byte Order Mark (BOM)
http://en.wikipedia.org/wiki/Byte_order_mark

Source: http://en.wikipedia.org/wiki/Byte_order_mark
RosenCruz
deanhills wrote:
RosenCruz wrote:
Now I get this.

I did a fresh download latest WP. and I believe my config.php is clear and includes no empty lines. Weird

Rolling Eyes

Code:
Warning: Cannot modify header information - headers already sent by (output started at /home/rosencru/domains/ata-gdfghk.tk/public_html/wp-config.php:1) in /home/rosencru/domains/ata-turk.tk/public_html/wp-includes/pluggable.php on line 1121


I find this solution?
Quote:
If you get this error and dont have any spaces or line breaks in wp-config.php outside <?php and ?>, check that the wp-config.php is saved as utf-8 without BOM

Source: http://wordpress.org/support/topic/pluggablephp-on-line-1121

and
Quote:

Hi There!

1- Download wp-config.php from your server.
2- Open Notepad++ (really you don't have it?) open wp-config.php
At last of wp-config.php erase the code ;> if it writing there.
3- Go to menu Enconding and select 'Enconde in UTF-8 without BOM'.
4- Uploading wp-config.php to your server.

That's it.

Download Notepad++
http://notepad-plus-plus.org/download/v6.5.5.html

Information about Byte Order Mark (BOM)
http://en.wikipedia.org/wiki/Byte_order_mark

Source: http://en.wikipedia.org/wiki/Byte_order_mark


Thanks for the hard work Dean.

I actually tried with my another blog's config.php, modified it according to details here on FH server db and username, still it was not working Crying or Very sad


I gave up and decided to work on sth else, GetSimple CMS

http://get-simple.info/

Installation was easy, all FTP and installation did not take more than 15 minutes. Works very fast, has less options and customizations than WP of course. I kind of liked it and currently getting better at using it.

Here is my hello world page

http://www.bedavaseyler.tk
deanhills
RosenCruz wrote:


Here is my hello world page

http://www.bedavaseyler.tk
I love simple, and I definitely like the layout. Well done Rosen! Going to check out GetSimple, I like this style. Cool
dude_xyx
I have started testing this CMS too. It's simple and No need of Data Bases. Also There are more themes which you can use.
RosenCruz
Quote:
I love simple, and I definitely like the layout. Well done Rosen! Going to check out GetSimple, I like this style.


Quote:
I have started testing this CMS too. It's simple and No need of Data Bases. Also There are more themes which you can use.




It really is a cool piece of software, definitely.

I ve been playing it for like an hour. No luck with showing my recently added posts on homepage. I guess, it is since it is not a blogging software but a CMS. The only thing is there is my hello world page, although I have added a few posts too.

Now I m still playing with it. It is extremely fast. I liked it and admin back-end is really lite. If only I could show my posts at home page Smile

@dude_xyx, let me know if you have the same problem Wink [/quote]
Related topics
Best WP plugins ?
2 Wordpress Plugins Installation Please? - 50 Frih$ [help?]
Wordpress Plugins Help - 50 FRIH$
Mose Wanted Wordpress Plugins
Best WORDPRESS Plugins list
Wordpress, plugins ?
Updating Wordpress
Wordpress plugins
Want to learn WordPress Plugins development
What all Wordpress Plugins do you use..??
WordPress Plugins
Best WordPress Plugins for unfair advantage over others
Wordpress - Plugins infaltables
Wordpress - Plugins infaltables 2
Useful WordPress Plugins
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.