FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Wordpress / Akismet Issue





RosenCruz
Anyone having problems with Akismet on Server 3 ?

Akismet suddently stopped working despite me having a valid key (still valid i confirmed) but somehow my WP installation can not connect with akismet.com

Has there been a configuration change on server 3 ? That prevents from akismet to work ?
medesignz
Same issue. I have implemented the referrer coding to the function.php and not had any effect on the amount of spam I am getting in the past few days. Any light on this please.
RosenCruz
Hundreds of bots making so many spams each day. I am currently manually approving all but taking too much time.

f this persists, I ll have to my domain elsewhere.

I believe this is caused by a server configuration change on Server 3. It was all working fine until 10 days ago. Crying or Very sad
medesignz
It may have also effected the ability to search for plugins using the dashboard > plugins > add new

Has this also happened on yours?
johans
I have also notice strange mysql error and when i check again it works fine.. I notice this strange performance 5 days now but this past 2 days works fine.
Phpaddict
As this in the akismet support page, this can be a bug on the updates at the server.
dude_xyx
Maybe FirHost staff might have disabled a related php function ? I use the WP Plugin called AntiSpam Bee in Hosts where I can't use Akismet.


http://wordpress.org/plugins/antispam-bee/
deanhills
Looks as though this happens when Akismet comes with an upgrade. There was a discussion about this at Frihost in 2010 in which Bondings participated. I'd imagine if one followed his example of researching the plug-in problems with Akismet at WordPress, it may come up with solutions. It's worth reading the whole discussion.
http://www.frihost.com/forums/vt-114052.html#945618

Check this discussion as well at WordPress. It may be an old discussion, but the solutions may still be applicable for now:
http://wordpress.org/support/topic/cant-run-auto-upgrade
airh3ad
No effect on my side so far. Smile
BigGeek
This seems to be going on still and I my website is unable to get to akismet.com.

Is anyone else still seeing this issue?

I was able to upgrade the plugin it says that all the servers are accessible, when I check akismet.com it says it is available. But the plugin says it is not working, and I am getting slammed with a thousand spam comments a day.

I messaged bondings about it. Should I message someone else?
BigGeek
I was wondering if anyone was even reading this thread any more and if this was ever going to get fixed?

I still have the problem even though everything checks as reachable. I haven't tried any of the fixes in the older posts yet, but from reading here they do not seem to correct the issue.

I guess I'll take the time to read the older posts and see what they suggest doing to fix the problem. But I am still posting in the hopes that we will get some sort of update on what the problem is and if it is going to be fixed?

Thanks! Question
deanhills
BigGeek wrote:
I was wondering if anyone was even reading this thread any more and if this was ever going to get fixed?

I still have the problem even though everything checks as reachable. I haven't tried any of the fixes in the older posts yet, but from reading here they do not seem to correct the issue.

I guess I'll take the time to read the older posts and see what they suggest doing to fix the problem. But I am still posting in the hopes that we will get some sort of update on what the problem is and if it is going to be fixed?

Thanks! Question

Try this solution from Bondings in one of the older threads (Jan 2012) and see whether it works:

Bondings wrote:
I found the following on WordPress:
Quote:
Download and install this plugin manually: http://wordpress.org/extend/plugins/core-control/ Once you've activated it, Load the "Core Control" settings page and activate the "HTTP Module". Go to the new tab fore the "HTTP Module" and test cURL. You will most likely receive the following error message "An Error has occured: name lookup timed out" Now click the "Disable Transport" link in for cURL. You should now be able install plugins and plugin updates.

http://wordpress.org/support/topic/cant-run-auto-upgrade

Maybe this will help?

Source: http://www.frihost.com/forums/vp-1069604.html#1069604

The comments were mostly positive.
dude_xyx
Quote:
Download and install this plugin manually: http://wordpress.org/extend/plugins/core-control/ Once you've activated it, Load the "Core Control" settings page and activate the "HTTP Module". Go to the new tab fore the "HTTP Module" and test cURL. You will most likely receive the following error message "An Error has occured: name lookup timed out" Now click the "Disable Transport" link in for cURL. You should now be able install plugins and plugin updates.


This did work and I was able to upgrade everything. But still time to time Akismet says not connected even though it's connected. I think connection problems happen. But this doesn't help Jetpack at all.
BigGeek
deanhills wrote:
BigGeek wrote:
I was wondering if anyone was even reading this thread any more and if this was ever going to get fixed?

I still have the problem even though everything checks as reachable. I haven't tried any of the fixes in the older posts yet, but from reading here they do not seem to correct the issue.

I guess I'll take the time to read the older posts and see what they suggest doing to fix the problem. But I am still posting in the hopes that we will get some sort of update on what the problem is and if it is going to be fixed?

Thanks! Question

Try this solution from Bondings in one of the older threads (Jan 2012) and see whether it works:

Bondings wrote:
I found the following on WordPress:
Quote:
Download and install this plugin manually: http://wordpress.org/extend/plugins/core-control/ Once you've activated it, Load the "Core Control" settings page and activate the "HTTP Module". Go to the new tab fore the "HTTP Module" and test cURL. You will most likely receive the following error message "An Error has occured: name lookup timed out" Now click the "Disable Transport" link in for cURL. You should now be able install plugins and plugin updates.

http://wordpress.org/support/topic/cant-run-auto-upgrade

Maybe this will help?

Source: http://www.frihost.com/forums/vp-1069604.html#1069604

The comments were mostly positive.


When you click on the link to the plugin is says that the plugin has not been updated in over 2 years and may have compatibility issues. So I have not downloaded and installed it on my site.

I can upgrade, and load programs with no problem, even used the auto update feature to update wordpress to the latest version, and it worked with no problems.

the problem I am having is that it says it cannot validate my Akismet key, I have regenerated the key twice and it still says it cannot validate the key. I upgraded the Akismet plugin using the auto update link on the plugin page, and it upgraded and says I have version 2.5.9.

After upgrading the plugin to version 2.5.9 my site says that a new version, 2.5.9 is available still, even though I upgraded, and it I get the error:

The key below was previously validated but a connection to akismet.com can not be established at this time. Please check your server configuration.

And it cannot validate the key. However the Akismet settings page shows all servers green, and the link to check Akismet.com works and displays a page that says it is working.

Any suggestions other than installing an outdated plugin to fix this?

It is getting really tedious to have to delete 1000 spam comments a day!!
BigGeek
Well I tried removing and reinstalling Akismet plugin, after I found the plugin folder and it still did not correct the issue.

So I downloaded unzipped the cURL plugin, uploaded the "core-control" folder into my "wp-content\plugins" folder activated it, went to the core control menu .... which was not so simple to find, it is under "Tools" and "Core Control" and enabled the HTTP Access module, tested it, and deactivated it like the instructions said, and the error on the key went away.

So this does fix the problem even though it is an older not updated untested plugin with this version of wordpress (3.6.1).

I guess we are testing it for them eh?

Thanks everyone for the help!
deanhills
This is great feedback BigGeek .... glad there's a workaround for it. Cool
Related topics
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.