FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


PHP version on Server 2/3 [Suggestion]





neiesc
The Server 2/3 are using version 5.2.17 I suggest moving to the same Server 1 5.3.25 or higher.

  • 5.2 - Release date = 2006-11-02, Supported until = 2011-01-06
  • 5.3 - Release date = 2009-06-30, Supported until = 2014-07
    Namespace support; late static bindings, Jump label (limited goto), Native closures, Native PHP archives (phar), garbage collection for circular references, improved Windows support, sqlite3, mysqlnd as a replacement for libmysql as underlying library for the extensions that work with MySQL, fileinfo as a replacement for mime_magic for better MIME support, the Internationalization extension, and deprecation of ereg extension.
  • 5.5 - Release date = 2013-06-20, Supported until = (expected 2016-06)
    Generators, Zend Optimizer+

http://www.php.net/ChangeLog-5.php#5.3.25
http://www.frihost.com/phpinfo.php
http://www.frihost.org/phpinfo.php

This is just a suggestion thank you all.
Peterssidan
I guess one problem is that it could break old code in some cases but personally I don't mind. Not that I have planned to use any of the new features but I have very little PHP scripts at the moment so it wouldn't be much of a problem updating them if necessary.
Qantas94Heavy
Peterssidan wrote:
I guess one problem is that it could break old code in some cases but personally I don't mind. Not that I have planned to use any of the new features but I have very little PHP scripts at the moment so it wouldn't be much of a problem updating them if necessary.


I'd think a transition period would take care of that for people with their own code, and most CMSs have an upgrade path to a PHP 5.3 compatible code base, if not already compliant.
Peterssidan
Qantas94Heavy wrote:
I'd think a transition period would take care of that for people with their own code

You mean have two versions of PHP available at the same time? Is that even possible?
sonam
Peterssidan wrote:
Qantas94Heavy wrote:
I'd think a transition period would take care of that for people with their own code

You mean have two versions of PHP available at the same time? Is that even possible?


Yes it is possible but server must use different extension for each. For example ones I am upload site on server where old version (before 5) use .php extension and new version after 5 use .php5 extension.

Nice solution for server where lot of sites use php 4.

Sonam
neiesc
There are many products using PHP >= 5.3

http://www.frihost.com/forums/vt-149719.html
Related topics
Reply to topic    Frihost Forum Index -> General -> Suggestions

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.