FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Joomla 3.0 article image problem.. MAGIC QOUTES





bluxberry
hi All first of all.
My problem is commercial as u know after i start to use joomla 3.0 i got problem about images.. and i thing its about magic qoutes.. before installation i change it from false the true in installation/models/setup.php than it lets you the install joomla but after when i wanna add image or photo from article doesnt Show the image..

Reason of it magic qoutes.. in code after i add the image from back end of joomla from article page image button its shows on backend but after save doesnt Show it. the code of image is like images/xxx.jpg after save button its adds /'s before and after and as a code its been like \\images/xxx.jpg// than its doesnt Show it.

i searched on net for solitions and couldt find anything about this topic.. the point from server conf we can do something .. or how i can fix it?
miteY
bluxberry wrote:
hi All first of all.
My problem is commercial as u know after i start to use joomla 3.0 i got problem about images.. and i thing its about magic qoutes.. before installation i change it from false the true in installation/models/setup.php than it lets you the install joomla but after when i wanna add image or photo from article doesnt Show the image..

Reason of it magic qoutes.. in code after i add the image from back end of joomla from article page image button its shows on backend but after save doesnt Show it. the code of image is like images/xxx.jpg after save button its adds /'s before and after and as a code its been like \\images/xxx.jpg// than its doesnt Show it.

i searched on net for solitions and couldt find anything about this topic.. the point from server conf we can do something .. or how i can fix it?


^^^^You can try the method I used.

I solved the magic quotes problem by adding the following code to both the top of my index.php file and administrator/index.php file of my Joomla 3.1 website.
Code:
. . .


EDIT: Hacking of Joomla core code is considered dangerous. Please refer to my newer posts on this thread to see a better way of solving magic_quotes problem for Joomla 3.

Hope this helps. Cheers! Smile
johans
Joomla 3.0 is not yet stable.. I strongly suggest you used Joomla 2.5 or just update your Joomla 3.0 to 3.1 - which is more better.
mahirh
Sounds like the perfect epidemic.
http://www.frihost.com/forums/vt-147739.html
http://www.frihost.com/forums/vt-148983.html
Wonder why.
miteY
mahirh wrote:
Sounds like the perfect epidemic.
http://www.frihost.com/forums/vt-147739.html
http://www.frihost.com/forums/vt-148983.html
Wonder why.

That's simple. Magic quotes. Aside from that, even though there is no stable version yet, Joomla 3 is still pretty decent IMHO.
manfer
Joomla 3.x has as a requirement magic quotes gpc turned off. So if your server has magic quotes on you have to disable them

Refer to the following message for the way to turn magic quotes off.
johans
try this.

magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
display_errors = Off
output_buffering = Off
bluxberry
i tried htaccess file in root folder but its also doesnt help to me.. maybe u are right and ineed to wait for steable version of Joomla 3.1 and do u know when its going to come ?
miteY
@all, I just completed a Joomla 3 site. I previously tried all other suggestions but when they didn't work I decided to hack Joomla code as shown in my previous post.

However, creating a .user.ini file in the root of your domain /public_html/ and putting the following code into it does the job without the need for hacking Joomla core code
Code:
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
display_errors = Off
output_buffering = Off


I will try to edit out my previous post to reflect this.

Cheers
tamilparks
miteY wrote:
@all, I just completed a Joomla 3 site. I previously tried all other suggestions but when they didn't work I decided to hack Joomla code as shown in my previous post.

However, creating a .user.ini file in the root of your domain /public_html/ and putting the following code into it does the job without the need for hacking Joomla core code
Code:
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
display_errors = Off
output_buffering = Off


I will try to edit out my previous post to reflect this.

Cheers


.user.ini file helps for me
Related topics
Magic Quotes GPC Off for Joomla 3.0
Joomla 3.0 Magic Quotes GPC Off
Joomla! 3.0 support
Any Support for Joomla 3.0 Magic Qoutes problem?
problem with save session path in joomla 1.0.15 installation
Problem with Folder Lock 6.3.0
Error Upon Installing phpBB 3.0.2
Opera 9.5 & Firefox 3.0 Not working. IE 7 Working. !?Pro
Rosanova's Site ver. 3.0
USB 3.0 SuperSpeed
Joomla 3.x requiresments and reccomendations
New mouse similar to Explorer 3.0
Install Mambo 4.5.2 And Vbulletin 3.0.7
The Best EJB 3.0 Flash PPT
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.