FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Wordpress: Php is not running





twotrophy
When I was trying to install Wordpress on my free web hosting account, it says that Php is not running. Wordpress requires Php in order for it to work. Is there any way to install Php in order to be able to install Wordpress?
sonam
PHP is installed for sure but maybe you need to configure wordpress. I cannot help you because I don't know nothing about wordpress but hope some member will give right answer to you.

Sonam
deanhills
Found this installation manual that provides an overview of all of the steps and what to upload to your public folder:
https://laughingsquid.us/faq/wordpress/install/

This tutorial gives more details about the config file that you have to create yourself:
http://www.wpbeginner.com/wp-tutorials/useful-wordpress-configuration-tricks-that-you-may-not-know/
twotrophy
I seem to be still unable to install Wordpress. I am new to web hosting so I do not know much about it. I heard that modifying the .htaccess file can be done to enable php. Maybe an administrator or Bondings can access my account for me to help me enable php. Here is what Wordpress says:

From: Wordpress CMS (URL hidden for a security purpose)

Quote:
WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.
truespeed
You get some code in your wordpress admin area to add to your htaccess file,I can't remember where in the admin area but it is there.
twotrophy
truespeed wrote:
You get some code in your wordpress admin area to add to your htaccess file,I can't remember where in the admin area but it is there.


Does the .htaccess file needs to be in the Wordpress folder? I am new to website hosting. Can someone provide the code to me please? After I am able to install Wordpress, I might want to try to learn how to install a free premium theme that looks very professional and neat. I might also use it for a game blog instead of my intended purpose of a test site for me to learn how to use a web host. Even if I use it for a game blog, I would still learn how to use a web host in the process of setting it up and maintaining it.

I prefer to use Frihost instead of Blogger or Wordpress because I can learn how to use a host instead of the situation where everything is set up for me. There are also no advertisments on Frihost.
cybersa
By default,PHP is enabled in your account.

Try this video,How to Install WordPress using DirectAdmin panel.


Short Procedure:
1.Upload a wordpress to your root directory.
2.Open your website,it will show you a Wordpress installation wizard.
3.Configure it.
twotrophy
cybersa wrote:
By default,PHP is enabled in your account.

Try this video,How to Install WordPress using DirectAdmin panel.


Short Procedure:
1.Upload a wordpress to your root directory.
2.Open your website,it will show you a Wordpress installation wizard.
3.Configure it.


This is the same video which I followed to put Wordpress files into DirectAdmin. I followed the instructions but got the PHP error. The Wordpress Instsllation Wizard does not work and the PHP code is visible in plain text which is an indication that it does not work. Thank you for trying to help me.
sonam
If I good understand what shared hosting means then all hosts on same server have the same server configuration. In that case if other users have installed PHP then you have too. Maybe the installation of Wordpress change some .htaccess or other files and now you get troubles.

My suggestion: PM to some moderator or account creator to see what happened and test PHP on your account.

Sonam
deanhills
@twotrophy. I found responses by Bondings to an exact query like this one of a year ago:
http://www.frihost.com/forums/vt-137335.html#1091932

And another one with plenty of tips in it from Bondings:
http://www.frihost.com/forums/vt-139100.html#1099940
truespeed
I have this code in my .htaccess file

Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


You will need to create a .htaccess file if you don't already have one in your root of your wordpress installation. paste that code in and hopefully it should work.
twotrophy
truespeed wrote:
I have this code in my .htaccess file

Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


You will need to create a .htaccess file if you don't already have one in your root of your wordpress installation. paste that code in and hopefully it should work.


I already have a .htaccess file on my public html file but it lacks these code. I will try to do it soon when I have the time. Also, does the .htaccess file needs to be in the Wordpress folder? Thank you for your help including Deanhills.
zimmer
sonam wrote:
PHP is installed for sure but maybe you need to configure wordpress. I cannot help you because I don't know nothing about wordpress but hope some member will give right answer to you.

Sonam


yup. agree php is not properly installed. try to re-install again.
truespeed
twotrophy wrote:
truespeed wrote:
I have this code in my .htaccess file

Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


You will need to create a .htaccess file if you don't already have one in your root of your wordpress installation. paste that code in and hopefully it should work.


I already have a .htaccess file on my public html file but it lacks these code. I will try to do it soon when I have the time. Also, does the .htaccess file needs to be in the Wordpress folder? Thank you for your help including Deanhills.


It should be mixed in with all your other wordpress files.
twotrophy
Unfortunately, it still does not work even after creating a .htaccess file. Maybe this would get the attention of an admin or even Bondings who can help me by editing my files.
Peterssidan
If you open a PHP file from within DirectAdmin it will not run the PHP code. You must access your WordPress pages using the normal/public URL.
twotrophy
Peterssidan wrote:
If you open a PHP file from within DirectAdmin it will not run the PHP code. You must access your WordPress pages using the normal/public URL.


Peterssidan, is there a way to tell what is my public Wordpress URLs? Thank you for your help.
Peterssidan
If your Frihost subdomain is twotrophy.frihost.org and you have installed WordPress in a directory named blog (inside public_html) then you should be able to find it at http://twotrophy.frihost.org/blog/
deanhills
twotrophy wrote:
I seem to be still unable to install Wordpress. I am new to web hosting so I do not know much about it. I heard that modifying the .htaccess file can be done to enable php. Maybe an administrator or Bondings can access my account for me to help me enable php. Here is what Wordpress says:

From: Wordpress CMS (URL hidden for a security purpose)

Quote:
WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.
Twotrophy, as far as I read the instructions, and the YouTube tutorial, it is you who have to activate the php through that configure sample file. You have to first save it as a configure file without the "sample" in it, then go in and add your database information in it. Then upload it to your Wordpress directory in your public folder.

The Wordpress installation process can't work until you have fixed the configure file properly and uploaded it together with all of the other files to the Wordpress sub-folder in your public folder.
twotrophy
deanhills wrote:
twotrophy wrote:
I seem to be still unable to install Wordpress. I am new to web hosting so I do not know much about it. I heard that modifying the .htaccess file can be done to enable php. Maybe an administrator or Bondings can access my account for me to help me enable php. Here is what Wordpress says:

From: Wordpress CMS (URL hidden for a security purpose)

Quote:
WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.
Twotrophy, as far as I read the instructions, and the YouTube tutorial, it is you who have to activate the php through that configure sample file. You have to first save it as a configure file without the "sample" in it, then go in and add your database information in it. Then upload it to your Wordpress directory in your public folder.

The Wordpress installation process can't work until you have fixed the configure file properly and uploaded it together with all of the other files to the Wordpress sub-folder in your public folder.


I have already removed sample in it. I just need to find the URL of my Wordpress. Does anyone know what URL do I need to type if I want to visit this page without using DirectAdmin?mso.frihost.org:2222/CMD_FILE_MANAGER/domains/mso.frihost.org/public_html/cgi-bin/Wordpress/wp-admin/install.php

Update: I have installed Wordpress. Thank you everyone for your help. Unfortunately, my next problem is that images would not load on the Wordpress panel.
Peterssidan
Maybe you should not put WordPress inside the cgi-bin directory.
Qantas94Heavy
Peterssidan wrote:
Maybe you should not put WordPress inside the cgi-bin directory.


Only CGI scripts should be in the cgi-bin directory - PHP's probably disabled there for security reasons.
twotrophy
Qantas94Heavy wrote:
Peterssidan wrote:
Maybe you should not put WordPress inside the cgi-bin directory.


Only CGI scripts should be in the cgi-bin directory - PHP's probably disabled there for security reasons.


Okay. Thank you a lot. I will remove Wordpress from the cgi-bin folder soon and I will see what would happen. Maybe that is the reason for images not being able to load. I managed to install Wordpress even when it is in the cgi-bin folder. Thank you for your help. I am new to web hosting.
Qantas94Heavy
twotrophy wrote:
Qantas94Heavy wrote:
Peterssidan wrote:
Maybe you should not put WordPress inside the cgi-bin directory.


Only CGI scripts should be in the cgi-bin directory - PHP's probably disabled there for security reasons.


Okay. Thank you a lot. I will remove Wordpress from the cgi-bin folder soon and I will see what would happen. Maybe that is the reason for images not being able to load. I managed to install Wordpress even when it is in the cgi-bin folder. Thank you for your help. I am new to web hosting.


No worries - Wordpress should be installed to /domains/example.com/public_html, or if you would like, in a new folder in public_html. Wordpress is amongst the easier ones around - if you need any more help it shouldn't be that difficult to use.
deanhills
I'm curious to know .... does DirectAdmin come with Softaculous?
truespeed
deanhills wrote:
I'm curious to know .... does DirectAdmin come with Softaculous?


No,but any install such as wordpress should be pretty straight forward anyway.
Related topics
Üyelerin Siteleri
ARRGG... Php can't Get to mySql
[PHP] Running Cron Jobs Via PHP Script
Which Linux distribution is the best?
Try method in php does not work
where to install php?
Apache/php running too slowly
Need help with file permissions for WordPress & plugins
Uploading an Image using PHP script - RESOLVED
PHP running PHP
ASP.NET
New CMS Web2.0 Templates
Apache/Php5/MySql = Complete Fustration
PHP Hangs On 2.2250738585072011e-308 (on some hardware)
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.