FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Disabling magic_quotes - Joomla 3





Limbless_One
Need magic_quotes turned of on the server side to install Joomla 3 , not sure who to PM to ask to have this happen.
So if you are a support tech and read this is this possible please ?
Confused
Sabbadon
Hi, I'm not from a tech supporter here, but I think you can manage it using .htaccess file in your public_html dir, you have to add this line:
php_flag magic_quotes_gpc Off

try and let me know
Limbless_One
Sabbadon wrote:
Hi, I'm not from a tech supporter here, but I think you can manage it using .htaccess file in your public_html dir, you have to add this line:
php_flag magic_quotes_gpc Off

try and let me know


Have already been through that and all the other ideas through many forums like making a "php.ini" file also and nothing works , this is my last resort so please no more add this add that to a certain file.
Thanks for your reply any way.

Crying or Very sad
Limbless_One
Well it looks like Frihost dose not support Joomla 3 at all .
well so be it.
k_s_baskar
Hi, I am not from frihost tech team. By default magic_quotes in on. tell me the server your hosted in . so that i can findout magic_quotes status.

you can also request to disable magic quotes for your domain and get solution like this http://www.frihost.com/forums/vt-135756.html
Smile
Limbless_One
k_s_baskar wrote:
Hi, I am not from frihost tech team. By default magic_quotes in on. tell me the server your hosted in . so that i can findout magic_quotes status.

you can also request to disable magic quotes for your domain and get solution like this http://www.frihost.com/forums/vt-135756.html
Smile


I am on server 4 and i have posted in the thread but i seem to get no replies.
miteY
If you still need to use Joomla 3 here, you can apply the method I used.

I solved the magic quotes problem by adding the following code to both the top of my index.php file and administrator/index.php file of my Joomla 3.1 website.
Code:
. . .


EDIT: Hacking of Joomla core code is considered dangerous. Please refer to the .user.ini method suggested later on this thread to see a better way of solving magic_quotes problem for Joomla 3.

Hope this helps. Cheers! Smile
zimmer
Limbless_One wrote:
Well it looks like Frihost dose not support Joomla 3 at all .
well so be it.


Joomla 3.1 works here at frihost.

Just PM me if you need help.
manfer
Just for anyone that needs this. There isn't any secret. There isn't any need to hack joomla code either. As joomla 3.x has as requirement to have magic quotes gpc turned off that's exactly what you have to do.

You have to use .user.ini files to turn it off as explained in .user.ini php documentation.

So just create in public_html folder a file .user.ini with the code needed to turn magic quotes gpc off
Code:

magic_quotes_gpc = Off
miteY
manfer wrote:
Just for anyone that needs this. There isn't any secret. There isn't any need to hack joomla code either. As joomla 3.x has as requirement to have magic quotes gpc turned off that's exactly what you have to do.

You have to use .user.ini files to turn it off as explained in .user.ini php documentation.

So just create in public_html folder a file .user.ini with the code needed to turn magic quotes gpc off
Code:

magic_quotes_gpc = Off

Please can someone confirm if this works, I don't have time to test it now.
Peterssidan
miteY wrote:
Please can someone confirm if this works, I don't have time to test it now.

Qantas94Heavy suggested this solution in another thread so I think it works.

Qantas94Heavy wrote:
For Joomla 3.0 a .user.ini file MUST be placed in the joomla directory or any of its parents, up to the document root (public_html). An example of a .user.ini file for Joomla 3.0 would be the following (in public_html):

Code:
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
display_errors = Off
output_buffering = Off


Make sure you deny access to the file by using .htaccess, or (if you want to be cheeky) fake a 404 page. This works as Frihost uses FastCGI for the servers.
miteY
^^^^ Thanks for your suggestion. It works flawlessly. I will edit my previous post to reflect this new change.

Cheers
zimmer
Peterssidan wrote:
miteY wrote:
Please can someone confirm if this works, I don't have time to test it now.

Qantas94Heavy suggested this solution in another thread so I think it works.

Qantas94Heavy wrote:
For Joomla 3.0 a .user.ini file MUST be placed in the joomla directory or any of its parents, up to the document root (public_html). An example of a .user.ini file for Joomla 3.0 would be the following (in public_html):

Code:
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
display_errors = Off
output_buffering = Off


Make sure you deny access to the file by using .htaccess, or (if you want to be cheeky) fake a 404 page. This works as Frihost uses FastCGI for the servers.


This wont work on Joomla 3.1.5

Any other suggestions?
Peterssidan
zimmer wrote:
This wont work on Joomla 3.1.5

Why not?
sinjhc
save the following
magic_quotes_gpc = Off
in php.ini and put the file in both Joomla root and installation folder
Related topics
About Joomla!
Do you use Joomla?
what is Joomla and does is it really helpful?
How to turn Magic Quotes off
Joomla 3.x requiresments and reccomendations
Best Joomla Tutorials
Magic Quotes GPC Off for Joomla 3.0
Joomla! 3.0 support
Joomla 3.0 Magic Quotes GPC Off
Any Support for Joomla 3.0 Magic Qoutes problem?
Joomla 3.0 article image problem.. MAGIC QOUTES
Joomla 3.x and PHP
Joomla 3.0 Help
Joomla 3.2 install
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.