FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Iframe issue with Opera, mostly solved





SonLight
This morning, when I try to reply to a post, I see all the html tags with the previous posts. I PM'ed Bondings because I thought it might be a general problem, but he says it's not. I verified it works correctly with Firefox and Chromium, so the problem is probably unique to Linux and Opera. I haven't updated Opera recently, although it might use dynamic libraries which were updated last night.

Here is a sample of what I see, copied and pasted from the displayed page:

Quote:
Topic review
<table border="0" cellpadding="3" cellspacing="1" width="100%" class="forumline"> <tr> <th class="thCornerL" width="22%" height="26">Author</th> <th class="thCornerR">Message</th> </tr> <tr> <td width="22%" align="left" valign="top" class="row1"><span class="name"><a name=""></a><b>darthrevan</b></span></td> <td class="row1" height="28" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0"> <tr> <td width="100%"><img src="templates/subSilver/images/icon_minipost.gif" width="12" height="9" alt="Post" title="Post" border="0" /><span class="postdetails">Posted: Thu Oct 18, 2012 12:40 pm<span class="gen">&nbsp;</span>&nbsp;&nbsp;&nbsp;Post subject: </span></td> </tr> <tr> <td colspan="2"><hr /></td> </tr> <tr> <td colspan="2"><span class="postbody"></span><table width="90%" cellspacing="1


Workarounds for this problem:
1. Use another browser.
2. Ignore previous posts in the thread.

Suggested possibilities:
1. Opera uses an updated library which now fails.
2. The installation, or the running program, has somehow become corrupt.
3. Some minor change on Frihost generally works, but is parsed incorrectly by Opera.

-- more to come -- ???

PS. Bondings, Opera always reports as version 9.8 because some sites started testing for that a few years ago. The 12.02 does appear at the end of the string.
darthrevan
If you have updated Opera or its libraries and it worked with a previous version, I would report this to Opera, since it sounds like a issue with the browser instead of Frihost itself. It definetly sounds like Opera specific issue to me as well. I don't use Opera on the desktop(Linux) but I do use it on my phone and no problems there.
SonLight
Mystery solved, although I'm still confused about how I managed to get the settings wrong. I had Iframes disabled. I'm still not sure how or why I did it, although I was debugging other sites and anything is possible. Apparently my default is now to disable iframes for all sites unless I explicitly enable them on a specific site.

The "quick preferences" option sets many of the defaults, but I don't see how to enable or disable iframes by default for all sites. As far as I can see, iframes are mentioned only in the "site preferences" section, and that menu item is disabled when no site is displayed in the current window. Probably I will have to enable iframes on a site-by-site basis as needed, or maybe the default can be set in about:config.
darthrevan
SonLight wrote:
Mystery solved, although I'm still confused about how I managed to get the settings wrong. I had Iframes disabled. I'm still not sure how or why I did it, although I was debugging other sites and anything is possible. Apparently my default is now to disable iframes for all sites unless I explicitly enable them on a specific site.

The "quick preferences" option sets many of the defaults, but I don't see how to enable or disable iframes by default for all sites. As far as I can see, iframes are mentioned only in the "site preferences" section, and that menu item is disabled when no site is displayed in the current window. Probably I will have to enable iframes on a site-by-site basis as needed, or maybe the default can be set in about:config.


Glad you got the issue solved. Enjoy seeing Frihost how it is suppose to be Smile
Related topics
*OFFICIAL* Which Browser do you use?
Installment Erro---Plz help me!
The Official FriHost IRC Channel!
What do you think about breastfeeding ?
READ THIS FOR SERVER2 STATUS -DONT MAKE NEW POST PLS!!
Internet Explorer Bug
Can't upload pages via FTP
Bush Broke the Law?!?
FakeWorld Website
Backup lost. Partition recovery
Softwares for Command Line Freaks...
problems adding domain
in need of an overview of the basic things
Opera 10.52 is Freaky Fast
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Frihost Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.