FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Nutch





BlackSkad
While working on the forumproject, I encountered an error with a array, but I have absolutely no idea what's wrong.
I include a file in which the array is declared, but when I want to output an item from that array, it says "Nutch".
Someone who knows what to do?

EDIT: Appearantly, it takes the first letter of the last item of the array (N in this case) and the name of the language (dutch). Realy strange, if I change the last item to start with a G, it gives Gutch.
But when using the english templates, everything works fine... weird
ml
well, you could for intstance show us some source code.
i think the arrays where the error happens are declared in a different way tha standard one is
BlackSkad
If I need to show you the source-code, then I need to post almost my complete-forum-script before you would understand a thing of what I'm doing.

But the declaration of the items happens like this:
Code:
$lang['index'] = "Index";
$lang['hello'] = "Hallo";


But as I've said, I use almost exact the same code in a english-document, only the part between "" is changed. The English document works fine, the others don't...
tyxl
shure you didn't remove the " or ' or; somewhere? in your real code then
BlackSkad
Yes, I'm very sure. I use phpeditor 2005. It has a highlighting functions, so I would immediatelly notice when I forgot one...
BlackSkad
No need to care about this topic anymore. A variable $_GET['lang'] was the guilty one. He messed up the script, in a stranged way...

But thanks for the help anyway Smile
Related topics
How to prepare a "robots.txt" to get crawled by Se
This topic is locked: you cannot edit posts or make replies.    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.