FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


"PHP is not running" while trying to install WordP





Zelen
Good evening. I uploaded WordPress to my host after having filled the config form correctly. I opened the 'install.php' file and the only thing I encountered was a window that said "PHP is not running" (here is the screenshot):


I already set up the data base and put the correct username and password on the corresponding config file. If anybody helped me install WordPress in my site I'd be very thankful.
Bondings
I uploaded a test.php file to your public_html directory and it is being executed. I'm not sure what caused the previous problem, but it seems fixed now.

I also checked your domain(public_html) and it seems like you have changed most files/directories to 777. Due to the current server configuration, this is causing an error (which you can check in the error log, in the statistics/logs page in DirectAdmin). For your WordPress to work, you'll need to change the permissions of the directories to 755 and the files to 644.
Zelen
Is it possible to do it automatically? I'm doing it manually and I feel as if I were to forget a file any moment and the whole think wouldn't work and I'd have to search all over again for that little file that I forgot to change from 755 to 644 (I set a 755 recursive change of permissions of all the WordPress folders).
Bondings
Zelen wrote:
Is it possible to do it automatically? I'm doing it manually and I feel as if I were to forget a file any moment and the whole think wouldn't work and I'd have to search all over again for that little file that I forgot to change from 755 to 644 (I set a 755 recursive change of permissions of all the WordPress folders).

I changed the files in your public_html to 644 permission and it seems to be working fine now. I also renamed the index.html file as it was preventing the index.php file from loading.

In the DirectAdmin file manager if you click on select, it ticks all the files/directories. Just unticking the directories and clicking on "set permission" to 644 fixed it. Next to the button there is also a "recursive" option that you can use for directories, but as your Wordpress seems to be working now, I don't think it is needed.

By the way, the problem is files/directories with 777 permission. Both 755 and 644 should be fine (not giving an error at least).
Related topics
How to solve this problem? Thanks
Post- Nuke
Moveable Type Install
Installment Erro---Plz help me!
PHP DB Error: syntax error
Hhow many of these can people solve?
phpbb help
phpbb installation
joomla permissions
Joomla Problem!
permission to access /install.php
Error with PHP-Nuke 7.8
Duel CPU's while trying to game?
O My, my php forum cannot be installed
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.