FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


WAMP Problem: Wont go to Localhost





Possum
Hi

I just installed the latest version of WAMP. Now when I click

WAMP LocalHost



all I get is

Forbidden

You don't have permission to access / on this server.


I can fix this if I type in http://127.0.0.1/ But I need Localhost.

Any Pointers please..

Thank you
cybersa
I recommend Xampp.
It is better than Wamp and has more features.
You can get it from here:
http://www.apachefriends.org/en/xampp-windows.html
clubdeinovaristi
cybersa wrote:
I recommend Xampp.
It is better than Wamp and has more features.

So do I.
I wanted to help you but I couldn't get the sources (I'm not using Windows and so I can't test it).
Sorry.
Robert_Redbeard
I'm not sure how to help. I have the same test server on my desktop. But I am not having that problem. Are you sure you have a page for it to default to when you go to Localhost?

Mine goes right to my index page that is in my www folder. But I am just learning how to use this.
cybersa
I think it's firewall problem.
If not,try to reinstall it.
Possum
It just seems strange that after 4 years of using WAMP that this happened.

I just use it for testing my forums and website..

Lucky I have WAMP on another computer. I did install XAMPP and it did do to Localhost. But I am used to WAMP..

That will teach me for updating
Robert_Redbeard
I actually use two different test servers.

You should see what happens when they start getting confused. LOL!!!

One is strictly for my Drupal testing. The other is for use with Dream Weaver.

My problem with the one is that since it is linked to Dream Weaver, when I save an image in Photoshop it always makes an images folder and puts my saves in there. Which makes things a pain. It even does it when I am saving images that have nothing to do with Dream Weaver sites I am building. And it has something to do with setting up the sites in Dream Weaver on the test server.
Possum
I think the problem is in the host file




Code:
# localhost name resolution is handle within DNS itself.
#       127.0.0.1       localhost
#       ::1             localhost


I need to allow localhost.

But I cant save my edits..

How can I do this?

Thank you..
Possum
It was the host file..

I used MS fixit to fix the Host file

http://support.microsoft.com/kb/972034


I then uninstalled WAMP. When I installed it it worked perfectly..
sonam
I am using host file for my server, too. Because my server allow me to have different names and different folders anywhere on my computer or network for each localhost site I need to define host file with right name. I am just open this file with notepad and type for example (note: without # in front):

Code:
127.0.0.1       localhost
127.0.0.1       somesite
127.0.0.1       someothersite



Sonam
Marcuzzo
Possum wrote:
I think the problem is in the host file




Code:
# localhost name resolution is handle within DNS itself.
#       127.0.0.1       localhost
#       ::1             localhost


I need to allow localhost.

But I cant save my edits..

How can I do this?

Thank you..


You need to open the file in administrator mode.
right-click on Command prompt and run as administrator.
type: notepad
hit enter.
drag and drop the host file in notepad and you'll be able to save the file.
inuyasha
I came up with the same problem, too. You have to modify the "httpd.conf"~
Search
Code:
<Directory "e:/wamp/www/">
, skip the comments and you will see this.
Code:
Order Deny, Allow
Deny from all
Allow from 127.0.0.1

I can't understand. The configuration seems perfectly reasonable. But you have to change it to
Code:
Order Allow,Deny
Allow from all

By the way, "Allow from all,localhost" won't work as well. It may be a bug of the new version.
Related topics
problem on advance guestbook
Anyone else having a problem with the 1.5 beta from Mozilla?
simple webserver on cable line.
A PHP problem !
SMTP problem
Problem with my site.
Problem logging in to Cpanel and FTP
DirectAdmin login Problem
.sql problem
Problem with Nvidia Card and Dual View
Problem
IIS unable to be connected using localhost(127.0.0.1)
How to Set up Local Web Server
Question about safe input from text boxes
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.