FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Directory is writeable by group - Apache error





Dementei
The error:
Code:
[Fri Feb 10 01:22:05 2012] [error] [client 75.185.xxx.xxx] SoftException in Application.cpp:564: Directory "/home/dementei/domains/nonstopdiscgolf.com/public_html/wp-content/themes/goodnews/framework/scripts" is writeable by group, referer: http://www.nonstopdiscgolf.com/
[Fri Feb 10 01:22:05 2012] [error] [client 75.185.xxx.xxx] Premature end of script headers: timthumb.php, referer: http://www.nonstopdiscgolf.com/


I am not sure about this error but I read that the following rules [ 1234234,340151 ] need to be added to mod_security for www.nonstopdiscgolf.com, and request the domain to be white listed for this Timthumb script to work if setting the proper permissions for the directories does not work.

So I've set the permissions to 755 and 777, both don't seem to work so if an admin can look into this for me that would be awesome.

Here's link to info about this common problem.
http://www.elegantthemes.com/troubleshooting-timthumb.html

Also in the /home/dementei/domains/nonstopdiscgolf.com/public_html/wp-content/themes/goodnews/framework/scripts folder the files read:

Code:
<?php die('Execution denied!');
Bondings
Most likely you need to change the permissions of the directory to 755 and not 777. With the current server configuration you most likely never need 777 permissions, 755 is enough and more will give errors. Changing directories (or files) from 777 to 755 usually solves these kind of problems.

Anyway, I changed the themes, goodnews, framework and scripts to 755 (2 or 3 of those were 777). Does this solve the problem?
Dementei
Thanks Bondings, yea I've tried those 3 dirs with both 755 and 777, I just now trashed the old posts and made 3 new posts with 3 different featured images and they appear as broken still, so what should we try now?
Bondings
wp-content and themes were still/again set to 777, so I changed them both to 755. Is there an url that I can check that is giving the error?
Dementei
Yo it's all set now somehow, I guess it was just the permissions after all. Thanks for your help, I can now continue the site.

..........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Related topics
apache server logs not working
Error Log Is Missing
Error document not found
about Apache Usage Log
Always error in server 2
[help]fatal error eso dice mi web
FTP and PHP
Apache Error Logs
Apache
I can not access my error log file
[Solved] Perl scripts
* * * * Apache problems in WAMP 2 server * * * *
500 internal server error upon executing PHP file
Classic Noobie PHPBB3 questions
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.