FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


PHP Directives





rodexa
Joomla 2.5 recommends to turn Display Errors and Magic Quotes Runtime off. If i put this in a .htaccess file all i get is a 500 Internal Server Error. How to turn these off? Can i use a custom php.ini or is this not allowed? And is the function ini_set disabled on frihost?

Thanks,
sonam
rodexa wrote:
Joomla 2.5 recommends to turn Display Errors and Magic Quotes Runtime off. If i put this in a .htaccess file all i get is a 500 Internal Server Error. How to turn these off? Can i use a custom php.ini or is this not allowed? And is the function ini_set disabled on frihost?

Thanks,


I don't think you can use custom php.ini but how I know ini_set is not disabled on frihost. In that case you can simple enable error warnings with

Code:
ini_set("display_errors", "1");


Sonam
rodexa
Thanks sonam, for your reply. I'll give it a try.
sonam
rodexa wrote:
Thanks sonam, for your reply. I'll give it a try.


I am just find how magic_quotes_runtime are DEPRECATED, and my suggestion is keep it off.

http://www.php.net/manual/en/info.configuration.php#ini.magic-quotes-runtime

Sonam
rodexa
Does anyone know in which file in Joomla 2.5 I need to put
Code:
ini_set("display_errors", "0");
and
Code:
ini_set ('magic_quotes_gpc', 0);

to turn off display_errors and magic_quotes_gpc? I've tried different files but without success.
k_s_baskar
By default magic_quotes_runtime is off. (In server 2 it is off to check vitist: http://pcprice.frih.net )

If you are unsure just create a php file with the line phpinfo(); and upload to your hosting account and access the file and check. Smile
rodexa
k_s_baskar wrote:
By default magic_quotes_runtime is off. (In server 2 it is off to check vitist: http://pcprice.frih.net )

If you are unsure just create a php file with the line phpinfo(); and upload to your hosting account and access the file and check. Smile

Thanks, but i'm talking about magic_quotes_gpc. This is enabled... even on server 2.
miteY
rodexa wrote:
Does anyone know in which file in Joomla 2.5 I need to put
Code:
ini_set("display_errors", "0");
and
Code:
ini_set ('magic_quotes_gpc', 0);

to turn off display_errors and magic_quotes_gpc? I've tried different files but without success.


Try putting it in the index.php file in the root directory of your joomla installation immediately after the <?php tags before any other tags.

Hope that helps.
Related topics
http://tuvanonline.com/library/index.php
PHP-Nuke platium?
PHP Write to line
Anyone good with PHP-NUKE?
PHP safety?
req: PHP to list files in directory, and link to them
php admin and mysql admin console
Mysql And PHP HELP PLZ
Great php editor
GD
Why some script tags must put in the head of document?
Disabling Magic Quotes
Joomla 3.x requiresments and reccomendations
Joomla 3.0 Magic Quotes GPC Off
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.