You are invited to Log in or Register a free Frihost Account!

Windows 7 Default Programs Setting

Hi everyone. The setting of default programs for file extensions on my windows 7 PC is not working, whichever way I try it. I right click the file and choose "Open With", the program is not listed so I browse to the EXE file, but it does not populate the "Open with" dialogue with the program I choose. The extension in question is .pub, which is only associated with Microsoft Office 2010 at the moment (no program in particular and therefore error appear and the file doesn't open). This is extremely frustrating, and the only thing I have found wrong with windows 7 so far.

I have trawled the internet for fixes to this and people just cannot seem to grasp that the normal way of doing things, wither through the "Open with" dialogue, or the "Default Programs" settings don't work. When you browse to the MSPUB.EXE executable, and select it, it does not add it to the list to set as default. The only way around it is to open publisher, then open the file from there.

Is anybody able to assist at all? Many thanks in advance.
Yes. I've always hated the default programs / open --> search for a program to open on the internet. Microsoft's file associations settings are seriously difficult to work with. Here's what you need to do to fix file associations for any .pub file:

Warning: Before continuing, I should advise you that the registry is the backbone of Windows. Don't make changes to the registry, or you could destroy Windows or other programs. If you decide to try the steps outlined here, you should back up your computer's registry before doing so. The easiest way to do this is to create a system restore point (Type "System Restore" in your Start Menu's search bar, and then use the system restore program to create a new restore point).

1. Go to Start ---> Run, and type in regedit. Alternatively, use the Start Menu's search bar to look for "regedit.exe". Click on it to run the Registry Editor.

2. The registry looks like a bunch of folders in your computer. Those folders are really containers for values called "keys", that manually corresponds to different settings on your computer. Using the directory menu on the left, navigate to the following key: HKEY_CLASSES_ROOT|.pub

3. When you do, you'll see that .pub is an extension associated with the MSPub application. You can also see that there are several other branches beneath .pub, or there may be none at all.

4. Here's the tricky part. There should be two keys there, (Default) and Content Type. If there aren't, then here's what you need to do.

a. If there is no subfolder (called Publisher.Document.14) in the menu under the .pub folder, go to the File Menu, Click Edit, Click New, "Key". Call the key Publisher.Document.14. If, however, you see Publisher.Document.14 listed as a subfolder of .pub, ignore this step.

b. Select Edit from the File Menu, Click ---> New, "String Value". Type (Default) as the name and Publisher.Document.14 as the Data.
c. Select Edit from the File Menu, Click ---> New, "String Value". Type Content Type as the name and application/ as the Data.

5. Your file associations should be fixed. If they aren't, take a look at the .doc folder, and attempt to mimic the keys from there, changing "Word" to "Publisher".

6. If this feels too complicated, don't attempt it. The registry is NOT the place to muck about.
Related topics
Windows 7 Official Thread
Change Windows 7 Logon Screen
WinXP to Linux Instead of Windows 7
Windows 7 for 30 dollars/pounds!
windows 7 installation via USB
10 Reasons To Buy Windows 7 Professional (!)
Which is better: windows 7 or ubuntu9.10 ?
Windows 7 64 bit in Dell Studio 1555
Windows 7 Program Files
How To Make Start Menu Icons Smaller In Windows 7
[SevenVG RTM]Download Windows 7 RTM Theme for Windows XP
Windows 7 desktop gadgets
Change Your Windows 7 Login Screen Pic
Aero Themes No Longer Working in Windows 7 Pro
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

© 2005-2011 Frihost, forums powered by phpBB.