FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


RAM upgrade problem





Ankhanu
I'm in the process of upgrading my wife's desktop PC, an HP a1700n. It's running Windows 7 Professional

I've recently purchased a new CPU, PSU and RAM for the system, intending to max out the MB with the highest supported CPU and RAM, and upgrading the PSU to support a better GPU.

The MB is is a PASUS A8M2N-LA (NodusM3).

Today I installed an Athalon 64 x2 5000+, a 600W PSU and 4Gb DDR2 PC5300 (4x 1Gb).

When I booted up, the system reached the login screen very quickly, and I logged into my wife's user account. The new CPU and RAM showed up just fine in the system window, but, within 2 minutes the system locked up. I restarted and got the same result. Eventually, it stopped even reaching her account before locking up or simply rebooting.

Looking in BIOS, I couldn't find any settings that would need to be changed to use the new hardware, and I decided to start testing the components one by one. My first attempt was to leave in the new CPU and PSU and use the old RAM (2GB PC4200)... it ran just fine.

So, with the RAM being the apparent issue, I pulled out an Ubuntu install CD, reinstalled the 4 new RAM sticks and ran a memtest. The RAM passed the memcheck without any issues at all. With the RAM passing the test (and the HDD too, figured I'd check it while I was there), I tested again; same thing, it locked up and rebooted after about a minute.

I then tried running 2Gb of the new RAM, it seemed stable.
I tried 3Gb; it locked/rebooted.
I tried the other stick to make 3Gb; it locked/rebooted.
Currently I have in the two sticks that caused it to lock/reboot when testing @3Gb, and they're running fine, just like the other 2 new sticks did.

Any idea what the issue could be? It kinda seems like maybe the third RAM slot is buggered, but I'm not entirely certain. I figured I'd consult Frih before reaching in for more RAM stick juggling and testing the 4th slot with 3Gb configurations.
Bikerman
So let me summarise to see if I have it:
the machine locks/reboots when you go above 2gig of the DDR2 new memory, regardless of which actual sticks are in use. With 2 gig installed it works OK with any two sticks...
is that right?
Ankhanu
I haven't tested every permutation, honestly. Here's what's been done:

ABCD - fail
ABC - fail
ABD - fail
BCD - didn't test
AB - Good
CD - Good
AC - didn't test
AD - didn't test
BC - didn't test
BD - didn't test

I say I didn't test these, but, I have tested 2 sticks at 2Gb four times, paying attention to exactly which sticks were being used only in the last two test. I may have tested one or two of those pairs without paying attention... but it wasn't systematic.

In testing I also tested slots:
1234
123
12
but have not tested
124

The four sticks together passed all tests put forth by the Linux memory test, which implies that the sticks are all good. I was thinking about testing each stick individually, but the first test took 1.5hr to get through; I don't want to spend 6hr testing memory.

I'm thinking the problem is likely the MB, perhaps a bad slot... It may be dust; I have my wife bringing back a can of air to make sure the slots are clean... we'll see :/

I really hope it's not the MB, as, if I had to replace it, I'd rather go with an i5 or i7... but I just bought a new CPU Razz Bah.
Bikerman
If it is a bad slot then the question arises - why did it not fail with the old memory and why does it pass the memory test?
I would want to test the memory sticks properly and be sure of that before moving on to the m/board...
Ankhanu
Yeah, good point on passing the test, regarding slot integrity.
It didn't fail with the old RAM because it only used the first 2 slots of the 4... this set up doesn't seem to cause any problem with the old or the new RAM.


*sigh*
I was really hoping to avoid single stick memory tests; it's a pretty long term effort.
Ankhanu
Pillaged an IDE HDD from an old server, and I'm installing Ubuntu onto the system now (with all 4Gb of RAM installed).

I have a feeling that the issue might be Windows rather than the hardware. We'll see how Ubuntu runs once it finishes installing.

Before this, I then tested 3Gb using slots 124, failing with CDA and CDB, and tested 2Gb @ CB, which again worked fine.

EDIT - Installed and gave it a test; it didn't respond with 4Gb... then I realized I'd used a 32bit version, removed 1Gb and it's running fine on 3Gb RAM. I'm downloading 10.10 64bit now and will see if it'll work with all 4Gb.
Bikerman
This may be helpful
http://social.answers.microsoft.com/Forums/en-US/w7repair/thread/85cad5d1-dace-415d-9b06-5c609209e232
http://social.answers.microsoft.com/Forums/en-US/w7hardware/thread/19599c79-7937-4af4-a96a-9aec60955530
Ankhanu
Thanks, I'll take a peek at those.

Interestingly, Ubuntu 9.04 32bit installed just fine with 4Gb RAM installed, but didn't run until I reduced it to 3Gb. It ran for about an hour or so like this before I shut it down.
10.10 64bit isn't installing with 4Gb installed; it's rebooting before I get into the process of actually installing. I haven't pulled any of the RAM to give it another go. I'd gotten as far as starting to delete the HDD for the install before it reboot (first shot it rebooted as I was choosing my wireless network).

Huzzah for problem solving Razz
Related topics
Booting time
my girlfriend and linux.
Win xp handling over 2gb of memory
RAM or Graphics?
How to get more RAM?
Quality over Quantity! A big scheme!
Need help with RAM
PS2 emulator - PCSX2 0.9.2 R2 is now available
Will Vista work good on this computer?
[INFORMATICA] Verificador de Drivers
can xp run with 3 gb ram?
trying to get a better computer for gaming
RAM upgrade types
Time till new upgrade
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.