FRIHOST • FORUMS • SEARCH • FAQ • TOS • BLOGS • COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


I need help setting up a default index file?





jongoldsz
In the cpanel, what do I have to do to make the default index file, index.html?

This is my site: goldszmidt.us
This is my index file: goldszmidt.us/index.html


As you see my sites url gives a Forbidden error and a 500 internal server error, but with index.html included it works.
Bondings
jongoldsz wrote:
In the cpanel, what do I have to do to make the default index file, index.html?

This is my site: goldszmidt.us
This is my index file: goldszmidt.us/index.html


As you see my sites url gives a Forbidden error and a 500 internal server error, but with index.html included it works.

You need to remove the index.php file in order for the index.html file to work.

Also if you want to use the index.php file, you need to change its permission to 644, that's why it is giving an error at the moment.
Sunny
Quote:
In the cpanel, what do I have to do to make the default index file, index.html?


Seems you have an Index.php file too which is having permission problems.

if you want to use Index.php then you will have to CHMOD the file to 755. You can do this using a ftp client or even through file manager in Cpanel

If you want to use index.html rather then just rename index.php to lets say index1.php (won't recommend deleting it in case you need it afterwards)
jongoldsz
I just tried changing the index.php properties to 644 it worked, but I am still getting the error. Also, goldszmidt.us is an addon domain.
Do you have any othe ideas?

Also goldszmidt.us has no index.php file in its directory, but in the main directory there is.(I CHNOD the main directory one.)
Sunny
Pls go to Cpanel >>>Error Logs button >> and tells us the exact error it logging.
jongoldsz
This is the whole error log:

[Tue Oct 4 16:45:44 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:44:54 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:44:29 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:44:19 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:39:48 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:39:45 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:37:51 2005] [error] [client 71.245.243.239] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:37:36 2005] [error] [client 134.58.253.131] client denied by server configuration: /home/jongolds/public_html/goldszmidt/.htaccess
[Tue Oct 4 16:37:16 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:37:11 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:34:55 2005] [error] [client 203.122.31.110] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:34:46 2005] [error] [client 203.122.31.110] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:33:12 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:22:04 2005] [error] [client 71.245.243.239] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:10:07 2005] [error] [client 134.58.253.131] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
[Tue Oct 4 16:09:48 2005] [error] [client 203.122.31.110] Directory index forbidden by rule: /home/jongolds/public_html/goldszmidt/
Bondings
You disabled for some reason the directory index output and that's why it was showing the 500 error. Apparantly also the index.html file wasn't executed as a main file, so I had to add it into your .htaccess file before I got it to work.

Anyway, it's up and running now, like it should.
jongoldsz
Thank you, so much. Very Happy

Can you tell me how to do that for future reference?
Bondings
jongoldsz wrote:
Thank you, so much. Very Happy

Can you tell me how to do that for future reference?

Put the following in the .htaccess file:
Code:
DirectoryIndex index.html

If you want a different file as index, replace index.html by that file.
jongoldsz
Thanks.
Related topics
Please help regarding editing of index file
how to change the default index page
How To : Secure Your PHP Website
Default index.html
cgi guestbook... need help setting up.
How to prepare a Sitemap Index file for multi sitemaps
What΄s wrong with server 2
Domain name changing.
751 Useful Windows XP Files
Mambo Users
IStrip
ARG, need help getting web site up.
where is my index page in cpanel?!
Help setting a css for the sidebar : Blog
This topic is locked: you cannot edit posts or make replies.    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.