FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Mysql and PHP separately to work on windows 7





pollux1er
Hi to everybody. I get a problem with WAMP on seven, I tried to restore it with no success so I decided to use Php, Apache and Mysql separately to work on wy system.
The problem now is that, Mysql script on php pages are not responding, no errors, like if there was no mysql server on my system.
Please help to understand clearly how to use it because on mysql website, nothing is said directly managing php connections through a webpage.

Thanks in advance.
Bondings
Try to turn on the php errors, that might show something.

It could be that a port is blocked. It could be that you need to specify localhost in the settings. Or that your user doesn't exist or doesn't have access to the database.
pollux1er
Bondings wrote:
Try to turn on the php errors, that might show something.

It could be that a port is blocked. It could be that you need to specify localhost in the settings. Or that your user doesn't exist or doesn't have access to the database.


I did it. And it seems my php does not recognise mysql functions. Because mysql_connect() is an error of function.
rickylau
Are you using PHP5? Did you install / configure the MySQL library properly?


BTW, according to your messages, no significant reason could be suggested so far. You may take a look at the notes in the PHP manual above, there seems to be some posts discussing problems with Windows 7...
pollux1er
I reinstall MySQL server but i am still having a problem. MySQL Workbench can not connect to mysql server. The error message when i try to create a new instance connection is : "Your cconnection attempt failed for user 'root' from your localhost to server at 127.0.0.1:3306..."
Nemesis234
http://www.webdevelopersnotes.com/how-do-i/install-mysql-windows-7.php

maybe just check you did all the steps as listed here? sounds like you install mysql, then you need to link php to mysql.
jmraker
If a phpinfo() shows that mysql support is enabled and mysql_connect isn't a function then there's a problem.

If there isn't a seperate box or two with a few lines in it then the mysql module is commented out in php.ini
pollux1er
Thanks all of you. I don't really know what was wrong but everything is ok now. But MySQL Workbench is a bit bugging on the path to my.ini config file but mysql server is on and I execute scripts. Thanks
Echo51
I've had alot of trouble with WAMP on most windows machines i had, so i'd go wiht installing it manually Wink
Related topics
Seeking MySQL-php-Apache installer for WinXP
MySQL, PHP and APACHE
Windows 7 Official Thread
Windows 7 RC1 on a HP tx2000 tablet
Linux PHP or a Windows asp server?
windows 7 installation via USB
10 Reasons To Buy Windows 7 Professional (!)
Windows 7. Whats different about it
Mounting an ISO
Logon as Administrator - Windows 7 Home Premium
Safe Mode and MsConfig [Windows 7]
Tablets with Windows 7
Windows phone development in windows xp
MySQL on Windows 7 Home Premium
Instaling fedora over Windows 7
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.