FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Which php version on the new server? (5.2.12 or 5.3.1)






Which version of php on the new server?
5.2.12
40%
 40%  [ 20 ]
5.3.1
59%
 59%  [ 29 ]
Total Votes : 49

Bondings
Which php version should I put on the new server? I will either put the latest 5.2 or the latest 5.3.

Currently (since the problems), version 5.3.1 is installed and it deprecated a lot of functions, causing quite some errors to appear on some websites. So maybe it might be better to keep 5.2.12.

On the other hand, most of those problems can be fixed by upgrading your software, which should really happen because there are a lot of security bugs in the older releases that need to be fixed in order to avoid your software/account to be hacked. And those hacks may happen on any kind of website, even the smallest ones since it's frequently done by worms.

What do you think?
mOrpheuS
5.2.12 for now.

5.3.x compliant versions haven't been released for a lot of popular website software / addons.
It would make sense to upgrade when 5.2.x breaks more scripts than 5.3.x does right now.

Regarding the vulnerabilities, I think 5.2.x is still being actively developed/maintained. We can expect security updates for quite some time to come.

p.s. - This discussion should be featured.
nam_siddharth
I am always for newer versions. If we update existing server with newer versions, problems may arise. But since we are talking about new server, most of the websites there will be new, so there will not much problem.
ocalhoun
Well, when phpbb3 is broken by it, despite how new it is, I would feel very sorry for people using phpbb2 or other things of that age.

Why don't they just update their software?
-- Why doesn't Frishost update to phpbb3 rather than 2?
The same reasons, probably.

I'm with mOrpheuS on this one:
mOrpheuS wrote:
It would make sense to upgrade when 5.2.x breaks more scripts than 5.3.x does right now.


Especially in the case of popular website software packages that don't have a 5.3.x compliant version- Just think of all the complaints, even from new users, when people find out there's absolutely no way they can install the forum/gallery/blog/whatever they want, unless they completely revise the code of it themselves.

Extra security is good, but 99.9% of the sites on Frihost would place a higher priority on functionality rather than security.
Only websites with classified information, or dealing in financial transactions would want to potentially sacrifice working correctly for being secure.
Bondings
I didn't know that it caused that many problems. I thought it was just a few older software versions.

Anyway, I featured this discussion. (By the way, mOrpheuS, the featured discussions creation is done in the admin panel, so you have access to it.)

I'll probably use the latest 5.2 php version for the server, unless a lot of people come with very good arguments.
mOrpheuS
Bondings wrote:
I didn't know that it caused that many problems. I thought it was just a few older software versions.


The list of backward incompatible changes is huge.
And so is the list of deprecated features.

I was playing around with it when it first came out, and it broke 3 out of 5 sites that I tested it on.
Most of the stock scripts should work fine - it's the plugins/addons that will break mostly.

You can usually tell if a software version is good for general use if popular Linux distributions include it in their official stable repositories.
Debian, my distribution of choice, still includes only 5.2.6 in their official stable release. Shocked
Q5U8
I go for 5.3.1

The warnings can be hidden editing the php setting "display error" to off.

And at level user, we can hide the warning with a simple snippet of code in .htaccess

So I don't see any problem to stay upgrade to 5.3.1, we need more security and php 5.3.1 is the real secure version.
Ghost Rider103
I also say go for 5.3.1.

If we don't upgrade now, then we may never get upgraded without causing even more problems. So we might as well upgrade now rather than later, or we could be stuck with 5.2.12 for who knows how long.
deanhills
Bondings wrote:
Which php version should I put on the new server? I will either put the latest 5.2 or the latest 5.3.

Currently (since the problems), version 5.3.1 is installed and it deprecated a lot of functions, causing quite some errors to appear on some websites. So maybe it might be better to keep 5.2.12.

On the other hand, most of those problems can be fixed by upgrading your software, which should really happen because there are a lot of security bugs in the older releases that need to be fixed in order to avoid your software/account to be hacked. And those hacks may happen on any kind of website, even the smallest ones since it's frequently done by worms.

What do you think?

I'm not tech-wise at all, so my comment is strictly as a user only. I would go for the version that gives maximum protection from bugs in the Websites that can affect the Forum. During one of the times that we have been down you mentioned something about people doing strange things on their Websites, causing the Website to go down. So the version that can provide protection from those "Website bugs" may be attractive from that point of view. If there were errors that appeared on some of the Websites with 5.3.1 could they have been ones that could potentially have created problems for Frihost? Perhaps you are right then from that point of view. And maybe people should be updating the software on their Websites?

For me safety and security against hacking and a "bug free" environment would be highest on the list of priorities and if 5.3 can provide it, then hopefully everyone can get up to date as well.
polly-gone
Actually, as of right now, I am writing a book proposal for a PHP reference / manual type book, so I've done a LOT of research into the topic, ya know, deciding which functions / modules to include, what not to include, etc. It has taken really a whole lot of work, just because a lot of funcions are being deprecated in 5.3.x and many, many of those functions are being removed in 6.0.x.

After all the research I've done, I would DEFINITELY go with 5.2.x. It is still he actively developed and it will be for awhile, due to backwards compartability issues, and it will break the least amount of websites. It's a good version and it will be for a long while still.

-Nick Smile Smile Smile

EDIT: P.S. This is my 666th post. Creeeepy. haha
Bondings
Q5U8 wrote:
I go for 5.3.1

The warnings can be hidden editing the php setting "display error" to off.

And at level user, we can hide the warning with a simple snippet of code in .htaccess

So I don't see any problem to stay upgrade to 5.3.1, we need more security and php 5.3.1 is the real secure version.

I don't like the display errors to be off. If there is a problem with a page, you don't see it immediately and have to rely on the error log.

I think that once we go for real to php 5.3, then I'll leave the display errors on and so everyone will notice the warnings and fix them because that will be needed before upgrading to php 6. Leaving them off has no advantage, then it's better to stay at 5.2 forever.
rjraaz
I go with version 5.3.* there is no problem with my softwares / scripts mostly i use my own scripts and will contribute to original developers.
ocalhoun
Q5U8 wrote:
I go for 5.3.1

The warnings can be hidden editing the php setting "display error" to off.

You can hide the warnings, but the errors still happen, and still cause sites to malfunction.
Donutey
Hmmm, a hard decision. Are there any major software that require 5.3, without fallback options for 5.2? As long as there is a relatively clear/easy path to upgrade to 5.3 in the future I think 5.2 would be the better in the short term.
taytay
I Haven't had a Whole lot of time lately to keep my site developed to current php scripting standards, so the longer my scripts still work, they better. Like has been mentioned previously, lets keep with 5.2.x until 5.3.x is better in terms of functionality. Just to be sure I don't get any scripts suddenly broken, without the time to quickly fix them. In the mean time I'll be reading over the changes and making sure my site can handle the change. Although, I'm sure it can as it currently stands, It would be wise to take the time to look things over.
Hogwarts
I significantly doubt that the backward incompatible changes will affect even 5% of Frihosters unless they're using phpBB/some other premade website software which doesn't support 5.3, as most Frihosters use procedural code. If they're using phpBB or the like, they'll likely be doing a fresh installation anyway. Thus, you might as well go with 5.3 -- there's not much reason not to.
ocalhoun
Hogwarts wrote:
If they're using phpBB or the like, they'll likely be doing a fresh installation anyway.


...Unless they've already been using it for years...
Hogwarts
ocalhoun wrote:
Hogwarts wrote:
If they're using phpBB or the like, they'll likely be doing a fresh installation anyway.


...Unless they've already been using it for years...

In which case they're already on one of the old servers, or are a newcomer and probably are using the latest software anyway Rolling Eyes

And even then, if it was such a problem, I'm sure they could arrange to be hosted on one of the older servers. And even then, they would inevitably have to upgrade their site to be PHP 5.3 compatible. The positive thing about doing it when the server is created is that the errors are resolved during the creation and/or setup of the site. Otherwise, the server will be locked to 5.2 so that people don't whinge when their sites break once it's upgraded beyond 5.2 Rolling Eyes
Xanify
Upgrade. The more people adopt the new version, the faster it will be widely supported.
mOrpheuS
ocalhoun wrote:
Q5U8 wrote:
I go for 5.3.1

The warnings can be hidden editing the php setting "display error" to off.

You can hide the warnings, but the errors still happen, and still cause sites to malfunction.

I'm not sure if that's the case.

E_DEPRECATED, although technically an "error", should not cause broken functionality.

All it means is that usage of certain function is not recommended, and will not work with the future versions of PHP.

If we must upgrade, it makes sense to hide only this error level by default. (Saves a ton of support threads).
Users who wish to be notified about usage of deprecated functions in their scripts can enable reporting of this error level specifically for their sites.
Bondings
I have re-enabled the error reporting. I only disabled the E_DEPRECATED now.
anakin_skyrunner
I'd upgrade too. I guess that breaks some websites, but as Hogwarts mentioned, this won't effect as much as 5% of Frihost users.

Newer is better Smile
(I know that this is not true in all cases, but as far is I'm concerned php 5.3 is better)
wombatrpgs
Ugh, I'm running a PHPBB2 forum with heavy modifications... As I'm using outdated stuff, the outdated version performs much better.
Sickness
Joomla websites don't seem to work well with PHP 5.3. In my case, I would prefer to use the 5.2 version.
pscompanies
I think it's better to upgrade too.
mathiaus
What's easier for you to do Bondings? Install with 5.3 or install with 5.2 and then later upgrade to 5.3?

If people did have issues (and there were only a few people), could they be moved to another server?
Radar
Upgrade. I say this even though some things on my site have stopped working recently due to PHP being upgraded. That's mostly my bad for not keeping them better up to date though, and that's what you have to live with.

And, one day, sooner or later, there will have to be an upgrade.
rvec
CakePHP and Drupal only support PHP5.3 in the development version, and so do some other often used software packages. I'd say stay with the latest PHP5.2.x version for a couple of months, but upgrade to 5.3 before the end of this year. That way Frihost will support most websoftware, and upgrade to the new version when most active projects have supported PHP5.3. This way users will also be forced to upgrade, but not to build their own stuff, or hack existing software in order to stay on frihost.

Edit: also mambo has a fix, but it isn't in the stable version jet.
Bondings
rvec wrote:
CakePHP and Drupal only support PHP5.3 in the development version, and so do some other often used software packages. I'd say stay with the latest PHP5.2.x version for a couple of months, but upgrade to 5.3 before the end of this year. That way Frihost will support most websoftware, and upgrade to the new version when most active projects have supported PHP5.3. This way users will also be forced to upgrade, but not to build their own stuff, or hack existing software in order to stay on frihost.

Edit: also mambo has a fix, but it isn't in the stable version jet.

Indeed, I think this is the best solution. Php 5.3 still breaks too many software and not all of them have fixed the problems yet. At the end of the year (or even a bit later) this should have changed a lot.
lucian0127
Does this server (updated) can read lower version of PHP?
Bondings
lucian0127 wrote:
Does this server (updated) can read lower version of PHP?

Php 4 isn't supported anymore. We currently use php 5.2.
Hogwarts
Should this thread be un-stickied? Despite, from what I believe, you having already made a decision, the thread will be consistently bumped because it's a featured topic
Bondings
Hogwarts wrote:
Should this thread be un-stickied? Despite, from what I believe, you having already made a decision, the thread will be consistently bumped because it's a featured topic

Indeed, 5.2 has been chosen, so I unstickied this topic.
mshafiq
Me too., I took decision to use latest version.
It was hard to fix the issue due to errors/warning of deprecated functions, but finally it is OK now.
Thanks!
imagefree
i would prefer the latest version. although upgrading on my local PC broke manything (like the new GOTO in php caused problems because i already had a goto function).
Bondings
The problem is that a lot of popular software still doesn't support it. And considering that while fixing your own code isn't that hard, it would be a lot of work to fix that software yourself. So I'll most likely wait quite some time before upgrading. Maybe at the end of the year or something like that.
ganjour
PDO_SQLITE does not work in PHP 5.3.xx, read about this bug hear:
http://bugs.php.net/bug.php?id=48614
http://forums.cpanel.net/f5/undefined-symb...ion-148993.html
mOrpheuS
ganjour wrote:
PDO_SQLITE does not work in PHP 5.3.xx, read about this bug hear:
http://bugs.php.net/bug.php?id=48614
http://forums.cpanel.net/f5/undefined-symb...ion-148993.html

This bug is probably resolved in the final release versions.
pdo_sqlite extension loads and runs fine on my environment
johnfreemaniam
Yup...full recommedation for 5.2.12...will fix all issues....atleast 95%
Bondings wrote:
Which php version should I put on the new server? I will either put the latest 5.2 or the latest 5.3.

Currently (since the problems), version 5.3.1 is installed and it deprecated a lot of functions, causing quite some errors to appear on some websites. So maybe it might be better to keep 5.2.12.

On the other hand, most of those problems can be fixed by upgrading your software, which should really happen because there are a lot of security bugs in the older releases that need to be fixed in order to avoid your software/account to be hacked. And those hacks may happen on any kind of website, even the smallest ones since it's frequently done by worms.

What do you think?
milleja46
Wish i known of this(this is what i get for not paying attention and kinda falling away from this community). Because unless i can get a patch for a cms i use working i can't use their newest version(good thing i was only demoing the newest version right now and doing it on my actual site but on a subdomain for demo)
Asap170
Not to make you mad, but I am pretty sure there is a rule about posting on old topics. The last post was more than a year ago. It's a dead forum.
ocalhoun
Asap170 wrote:
Not to make you mad, but I am pretty sure there is a rule about posting on old topics. The last post was more than a year ago. It's a dead forum.

The rule being that one shouldn't resurrect an old topic unless one has something worthwhile to add to it.

I suppose it is debatable, but I think that post is worthwhile enough.
milleja46
ocalhoun wrote:
Asap170 wrote:
Not to make you mad, but I am pretty sure there is a rule about posting on old topics. The last post was more than a year ago. It's a dead forum.

The rule being that one shouldn't resurrect an old topic unless one has something worthwhile to add to it.

I suppose it is debatable, but I think that post is worthwhile enough.


Yea didn't mean to resurrect a old topic(of course i keep forgetting to check the date), but the post shouldn't get me in trouble as i was just mentioning my own fault in not realizing that when i tried demoing a cms on a personal subdomain which requires 5.3. Good thing there was a work around since this mgiht not be installed for awhile from how the topic resulted originally
Magikscape
I think upgrading would be nice, I like newer versions. Wink
Related topics
http://muonline.vn --> New server has copyright of Webzen
the new server?....(",)
Do i get Fantastico with your new server??
PHP version 5.0
PHP Memory on Server 2
Make your own PHP/APACHE/MySQL server at home.
php version
new php version
Upgrading server and inform users instead of a new server
Created by new off-line CMS
About downtime and new server replacing Server 2/3
Joomla! 3.0 support
php version?
PHP version on Server 2/3 [Suggestion]
Reply to topic    Frihost Forum Index -> General -> Suggestions

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.