FRIHOST • FORUMS • SEARCH • FAQ • TOS • BLOGS • COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Joomla Genel Yapılandırma- Internal Server Error





meseloz
Merhaba arkadaşlar,
Benim yönetim panelindeki genel yapılandırma sayfasını kaydetme ile alakalı bir sorunum var. Bu konuyu açmadan önce bu forumdaki ve başka yerlerdeki çözümleri okudum fakat hiç biri benim problemime ilaç olmadı. O yüzden ben de belki de son çare olarak sizlerden yardım istiyorum. Tecrübe ve bilgisini paylaşacak arkadaşlara şimdiden çok teşekkür ederim.
Sorun: Joomla admin panelindeki genel yapılandırma sayfasında bulunan "kaydet", "uygula" ve "iptal" tuşlarından herhangi birine bastığım zaman:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@XXXXXXXX.frihost.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at yyyyyyyy.xxxxxxxx.frihost.org Port 80


hatasını alıyorum.
Veriler:
- Bilgisayarımdaki siteyi frihost.com daki alanıma gönderdim. Aynı şekilde bilgisayarımdaki "database" i de gönderdim. Fakat söz konusu hata ile karşılaştım. Hatanın, taşıma sırasında oluşmuş olabileceğini düşünüp bütün siteyi ve veri tabanını sildim. Baştan temiz bir Joomla kurulumu yaptım. Fakat boş sitede de aynı hata devam etti.
- Ana makine linux sistemli, PHP 5.2.9 server 4
- Kullandığım Joomla sürümü 1.5.15 Türkçe
- Kurulum sayfasında kontrol edilen parametrelerden sadece "hataları göster" uygun olanın aksi olarak "açık" idi. Diğerleri istenilen şekilde.
- Siteye içerik ekleyip, silebiliyorum. Zaten siteyi ilk taşıdığımda büyük oranda düzgün çalışıyordu. Sadece modül aktif olmadığından veya benzer basit bir ayardan dolayı modülün biri gösterilmiyor idi. Siteye şu anda da giriş yapılıyor. Site düzgün açılıyor, çalışıyor.
- Modül, bileşen, tema kullanabiliyorum. Bunlarda sorun yok. Dediğim gibi tek anormallik "genel yapılandırma" sayfasında oluyor.
- Çözüme yönelik olarak da forumda tavsiye edilen şeyleri uyguladım ama sorun devam ediyor.
- ".htaccess" ile ilgili silme, temiz kurulumdan tekrar "htaccess.txt" yi yükleme gibi işlemleri yaptım, sonuç yok.
- Joomla'nın kendisininki de dahil hiç bir "SEO" eklentisi yok. Zaten yalın halde şu anda site.
- Dosya izinlerinin hepsini klasörler 755, dosyalar 644 olacak şekilde değiştirdim, sonuç yok.
- Genel yapılandırma ftp deyatları girilmiş vaziyette. Ftp: Aktif/Pasif değiştirdim (configuration.php üzerinden file zilla kullanarak elle), sonuç yok.
- Administrator klasörünün iznini 750 ve aşağı yaptım, sonuç yok.
- Yönetici paneli > Sistem bilgisi > Klasör izinleri sayfasında kontrol edilen klasörlerin hepsi "yazılabilir".
- "configuration.php" dosyasının iznini 644, 707, 777 vs. olarak değiştirdim bunların hiçbirinde de sonuç yok.
- Site subdomain adreste. Subdomain klasörü ile aynı seviye bir klasör daha var "cgi-bin" diye ve bunun içinde ".htaccess" dosyası var ve içinde sadece "Option -Indexes" yazıyor. Bunu kendi ".htaccess" imin en üst satırına yazma veya tam tersi; veya bunu subdomain klasörüne kopyalama veya tam tersi vb. kombinasyonları da denedim. Gene sonuç alamadım.
Defalarca soru-cevap olmasın böylece vakit kaybına neden olmayayım diye aklıma gelen bütün ayrıntıları verdim. Başka bilinmesi gereken aklıma gelmeyen bir şey varsa lütfen sorunuz. İlgilenecek arkadaşlara şimdiden tekrar teşekkür ederim. Görüşmek üzere...
darkeagle
meseloz wrote:
Merhaba arkadaşlar,
Benim yönetim panelindeki genel yapılandırma sayfasını kaydetme ile alakalı bir sorunum var. Bu konuyu açmadan önce bu forumdaki ve başka yerlerdeki çözümleri okudum fakat hiç biri benim problemime ilaç olmadı. O yüzden ben de belki de son çare olarak sizlerden yardım istiyorum. Tecrübe ve bilgisini paylaşacak arkadaşlara şimdiden çok teşekkür ederim.
Sorun: Joomla admin panelindeki genel yapılandırma sayfasında bulunan "kaydet", "uygula" ve "iptal" tuşlarından herhangi birine bastığım zaman:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@XXXXXXXX.frihost.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at yyyyyyyy.xxxxxxxx.frihost.org Port 80


hatasını alıyorum.
Veriler:
- Bilgisayarımdaki siteyi frihost.com daki alanıma gönderdim. Aynı şekilde bilgisayarımdaki "database" i de gönderdim. Fakat söz konusu hata ile karşılaştım. Hatanın, taşıma sırasında oluşmuş olabileceğini düşünüp bütün siteyi ve veri tabanını sildim. Baştan temiz bir Joomla kurulumu yaptım. Fakat boş sitede de aynı hata devam etti.
- Ana makine linux sistemli, PHP 5.2.9 server 4
- Kullandığım Joomla sürümü 1.5.15 Türkçe
- Kurulum sayfasında kontrol edilen parametrelerden sadece "hataları göster" uygun olanın aksi olarak "açık" idi. Diğerleri istenilen şekilde.
- Siteye içerik ekleyip, silebiliyorum. Zaten siteyi ilk taşıdığımda büyük oranda düzgün çalışıyordu. Sadece modül aktif olmadığından veya benzer basit bir ayardan dolayı modülün biri gösterilmiyor idi. Siteye şu anda da giriş yapılıyor. Site düzgün açılıyor, çalışıyor.
- Modül, bileşen, tema kullanabiliyorum. Bunlarda sorun yok. Dediğim gibi tek anormallik "genel yapılandırma" sayfasında oluyor.
- Çözüme yönelik olarak da forumda tavsiye edilen şeyleri uyguladım ama sorun devam ediyor.
- ".htaccess" ile ilgili silme, temiz kurulumdan tekrar "htaccess.txt" yi yükleme gibi işlemleri yaptım, sonuç yok.
- Joomla'nın kendisininki de dahil hiç bir "SEO" eklentisi yok. Zaten yalın halde şu anda site.
- Dosya izinlerinin hepsini klasörler 755, dosyalar 644 olacak şekilde değiştirdim, sonuç yok.
- Genel yapılandırma ftp deyatları girilmiş vaziyette. Ftp: Aktif/Pasif değiştirdim (configuration.php üzerinden file zilla kullanarak elle), sonuç yok.
- Administrator klasörünün iznini 750 ve aşağı yaptım, sonuç yok.
- Yönetici paneli > Sistem bilgisi > Klasör izinleri sayfasında kontrol edilen klasörlerin hepsi "yazılabilir".
- "configuration.php" dosyasının iznini 644, 707, 777 vs. olarak değiştirdim bunların hiçbirinde de sonuç yok.
- Site subdomain adreste. Subdomain klasörü ile aynı seviye bir klasör daha var "cgi-bin" diye ve bunun içinde ".htaccess" dosyası var ve içinde sadece "Option -Indexes" yazıyor. Bunu kendi ".htaccess" imin en üst satırına yazma veya tam tersi; veya bunu subdomain klasörüne kopyalama veya tam tersi vb. kombinasyonları da denedim. Gene sonuç alamadım.
Defalarca soru-cevap olmasın böylece vakit kaybına neden olmayayım diye aklıma gelen bütün ayrıntıları verdim. Başka bilinmesi gereken aklıma gelmeyen bir şey varsa lütfen sorunuz. İlgilenecek arkadaşlara şimdiden tekrar teşekkür ederim. Görüşmek üzere...


Sana da merhaba,
Aramızda joomla ile ilgilenen kaç kişi var bilmiyorum fakat ingilizce bölümlerde yada bi yetkiliye sorarak daha çabuk çözüm bulacağını düşünüyorum.
meseloz
İlgin için teşekkür ederim darkeagle. Zaten İngilizce bölüme yeni konu başlığı içinde, başvurumu kabul eden admin'e özel mesaj olarak ve de support center dan ticket olarak sorunumu 2-3 gün önce ilettim ama hiç birinden sonuç yok malesef. Sadece ingilizce bölümde 2 cevap vardı onlar da çözüm olmadı sorunuma. Elden birşey gelmiyor... Göçtüm ben de son çare olarak başka hosta. Yine de bir ümit... Bakayım diye giriyorum arada...
darkeagle
meseloz wrote:
İlgin için teşekkür ederim darkeagle. Zaten İngilizce bölüme yeni konu başlığı içinde, başvurumu kabul eden admin'e özel mesaj olarak ve de support center dan ticket olarak sorunumu 2-3 gün önce ilettim ama hiç birinden sonuç yok malesef. Sadece ingilizce bölümde 2 cevap vardı onlar da çözüm olmadı sorunuma. Elden birşey gelmiyor... Göçtüm ben de son çare olarak başka hosta. Yine de bir ümit... Bakayım diye giriyorum arada...


Yöneticiler az sayıda oldukları için cevap vermeleri geç oluyor, umarım bir çözüme kavuşursun...
dbase
sonuç elde edebildiysen bi bilgilendirirsen sevinirim
ultimatermof
Belki yardımcı olur: ben de moflink proxy listesini güncellerken bu hatayı alıyordum. Proxyleri bir formla gonderiyordum. Çok ip olunca gitmiyordu bazen. Ben de artık dosya olarak yüklüyorum. Böyle olunca sorun da çözüldü.
dbase
teşekkür ederim
ama
yardımcı olmadı
Sad
benim yaşadığım sorunda arkadaşla aynı
yönetim panelindeki genel yapılandırma sayfasını kaydetme ile alakalı
"kaydet", "uygula" ve "iptal" tuşlarından herhangi birine bastığım zaman:
"Internal Server Error" hatası alıyorum


arkadaş sorununa bi çözüm bulmuşsa paylaşsaydı pek güzel olurdu
meseloz
Buraya yazmamışım başka bir sayfaya yazmıştım heralde...

O zamanlar benim sitemin başka problemleri de vardı. Bazen hiç görüntülenmediği de oluyordu. Bondings açınca görünüyordu ben açınca görünmüyordu falan karışık bir mevzu idi. Soruna bir türlü çözüm bulamamıştık. Sonra Bondings o hesabımı kapatıp diğer server da başka bir hesap açmıştı "internal server error" hatası da yeni servera taşınınca kendiliğinden düzelmişti. Şu an joomla yı düzgün kullanabiliyorum. Ama bu taşıma işleminden önce düzelmiş mi idi onu tam hatırlayamadım.

Bondings ile yazışmalarımıza baktım en son mesajlar hesabı taşımaya ait olanlar idi...

"error_reporting(0);" ifadesini "<?php" ifadesinden hemen sonra hata aldığın sayfanın başına kopyala hata mesajlarını kapatmış olursun belki bu bir çözüm olabilir. Sonucunu yaz buraya gene yardımcı olmaya çalışırım.
ultimatermof
meseloz wrote:
Buraya yazmamışım başka bir sayfaya yazmıştım heralde...

O zamanlar benim sitemin başka problemleri de vardı. Bazen hiç görüntülenmediği de oluyordu. Bondings açınca görünüyordu ben açınca görünmüyordu falan karışık bir mevzu idi. Soruna bir türlü çözüm bulamamıştık. Sonra Bondings o hesabımı kapatıp diğer server da başka bir hesap açmıştı "internal server error" hatası da yeni servera taşınınca kendiliğinden düzelmişti. Şu an joomla yı düzgün kullanabiliyorum. Ama bu taşıma işleminden önce düzelmiş mi idi onu tam hatırlayamadım.

Bondings ile yazışmalarımıza baktım en son mesajlar hesabı taşımaya ait olanlar idi...

"error_reporting(0);" ifadesini "<?php" ifadesinden hemen sonra hata aldığın sayfanın başına kopyala hata mesajlarını kapatmış olursun belki bu bir çözüm olabilir. Sonucunu yaz buraya gene yardımcı olmaya çalışırım.


Hata Apache'den geliyor. PHP hatalarını gizlemek çözüm olmaz.
dbase
meseloz wrote:
Buraya yazmamışım başka bir sayfaya yazmıştım heralde...

O zamanlar benim sitemin başka problemleri de vardı. Bazen hiç görüntülenmediği de oluyordu. Bondings açınca görünüyordu ben açınca görünmüyordu falan karışık bir mevzu idi. Soruna bir türlü çözüm bulamamıştık. Sonra Bondings o hesabımı kapatıp diğer server da başka bir hesap açmıştı "internal server error" hatası da yeni servera taşınınca kendiliğinden düzelmişti. Şu an joomla yı düzgün kullanabiliyorum. Ama bu taşıma işleminden önce düzelmiş mi idi onu tam hatırlayamadım.

Bondings ile yazışmalarımıza baktım en son mesajlar hesabı taşımaya ait olanlar idi...

"error_reporting(0);" ifadesini "<?php" ifadesinden hemen sonra hata aldığın sayfanın başına kopyala hata mesajlarını kapatmış olursun belki bu bir çözüm olabilir. Sonucunu yaz buraya gene yardımcı olmaya çalışırım.


malesef çözüm işe yaramadı
meseloz
Dediğim gibi benim problem de o zaman server değişince hallolmuştu. Bu öneriyi Bondings bana yapmıştı belki sende işe yarar diye söyledim.

Joomla-tr de benzer başlıklar var "ınternal server error" ile ilgili bana onlar da ilaç olmamıştı ama sen istersen bir göz at yine de...

Daha da olmazsa Bondings'e söyle sana da başka server da yeni bir hesap açsın bence. Bu problemle alakalı hiç sordun mu daha önce Bondings'e?
dbase
meseloz wrote:
Dediğim gibi benim problem de o zaman server değişince hallolmuştu. Bu öneriyi Bondings bana yapmıştı belki sende işe yarar diye söyledim.

Joomla-tr de benzer başlıklar var "ınternal server error" ile ilgili bana onlar da ilaç olmamıştı ama sen istersen bir göz at yine de...

Daha da olmazsa Bondings'e söyle sana da başka server da yeni bir hesap açsın bence. Bu problemle alakalı hiç sordun mu daha önce Bondings'e?


diğer bölümlerdeki başlıkları da inceledim benim derdime de çare olmadılar
Bondings le irtibata bu problem için geçmedim sorunun benden kaynaklanmadığına kesin emin olmak istedim
şuan pek vaktim olmuyor uğraşmak için ama
bikaç şey daha deniyecem bakalım olmazsa son iş olarak irtibata geçecem

teşekküler.
Related topics
500 Internal Server Error
Internal Server Error
500 Internal Server Error!
Internal Server Error, what can I do?
500- Internal Server Error - DONT START NEW THREADS
Internal Server Error
500 Internal Server Error (please lock)
500 internal server error?
[help] 500 Internal Server Error server 1
Perl CGI 500 Internal Server Error
500 Internal Server Error
Internal Server Error in Joomla, Please help!
500 internal server error?
Joomla site with 500 Internal Server Error
Reply to topic    Frihost Forum Index -> Language Forums -> Turkish

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.