FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


phpmyadmin





alaham
I am a student of php/mysql. I have installed apache, php, mysql, phpmyadmin in local host. My operating system is Vista. Everything worked fine except phpmyadmin.

When I open phpmyadmin, It shows the error message " Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly."


Please advise..
rvec
you should take a look at your php error log. Or if this is only for testing you should turn on all errors (including notices) so you can see every error on the page.
rickylau
There's a solution I found in the Internet, with exact wordings to your error message, here's the solution for your reference.

- Set session.auto_start to "1" (Enable) from "0" (Disable) in php.ini
- Set $cfg['Servers'][$i][ 'auth_type'] to "http" from "cookie" in config.inc.php (phpMyAdmin)

This solution is just FOR YOUR REFERENCE only, I have not tested at all and you may try it at your own risk. Also, there may be more then one reason for the error message, which may have totally different solutions. I would suggest you to post more detail for your problem if you are not really sure what the above solution does (I'm not sure, too, so don't ask me).
cr3ativ3
I am very experienced with PHP and Apache, and how web servers run and operate (I personally use Linux for all my servers), however with the little experience about setting up servers on Windows... The probably your likely experiencing is due to the fact that php is trying to write to a temporary folder which is not writable by the process php or apache or whatever is running as... If you are still experiencing this problem, post all the session related settings in your php.ini file here. And perhaps we can help you out a little more Wink
raver
cr3ativ3 wrote:
I am very experienced with PHP and Apache, and how web servers run and operate (I personally use Linux for all my servers), however with the little experience about setting up servers on Windows... The probably your likely experiencing is due to the fact that php is trying to write to a temporary folder which is not writable by the process php or apache or whatever is running as... If you are still experiencing this problem, post all the session related settings in your php.ini file here. And perhaps we can help you out a little more Wink


Not sure about the issue, but if your description of the problem is correct, then the easiest solution is to run vista as an Administrator, in which case you can write anywhere.
I am assuming though that you did not install in the windows folder, therefore even as an user you probably can write to any folder.
Installing phpmyadmin works smoothly on windows XP, and on vista i run a xampp installation which includes phpmyadmin and works smoothly.
So my best guess is that you did something wrong when manually installing the software.
Diablosblizz
Raver is correct, Apache has issues with not being an admin. Personally, I'd install XAMPP because it's simpler and whatnot. Sure, it's not as rewarding but it gets the job done.
Related topics
phpMyAdmin
phpmyadmin
how ot connent to phpmyadmin?
How do you access phpmyadmin?
phpMyAdmin Gone?
PhpMyAdmin
phpMyAdmin Updated
[man]Servidor Web Personal (Tutorial)
sql with phpmyadmin
phpMyAdmin 2.6.4-pl1 error
PhpMyAdmin
PHPMyAdmin Login
Login Problems With PhpMyadmin
best phpmyadmin database exporting format
phpMyAdmin + calendar
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.