FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Getting error 15 when I try to boot Ubuntu





DoctorBeaver
I was installing Ubuntu from CD and we had a powercut while the installation was in progress. Now, when I try to boot it says "Grub loading 1.5 please wait..." then a couple of seconds later I get "Error 15" and nothing else happens.

I tried to install again from scratch but although the CD drive is accessed I get exactly the same error.

Basically, I'm stuffed. Any ideas? I've got USB memory sticks, an external hard drive, external CD/DVD drive (which I've tried but got the same error) and an SDHC memory card available if any of those could offer a solution.
AftershockVibe
You could try the steps here after booting from the install CD:
http://ubuntuforums.org/showthread.php?t=224351

Cool
DoctorBeaver
AftershockVibe wrote:
You could try the steps here after booting from the install CD:
http://ubuntuforums.org/showthread.php?t=224351

Cool


It won't boot from the install disk. With or without the disk I get error 15.
malcolmpreen
I had a similar sounding problem a while back.... can't remember the exact error... but I know I couldn't boot from the hard disk, or the ubuntu install media.

I was able to switch into debug mode (from grub I think.... but I'm not 100% sure) and that was suggesting that I had a problem which needed fscking....

Fine I thought.... if only I could boot somehow....

Anyway.... long story short.... I happened to have a Fedora 10 installation DVD.... I was able to boot that OK.... enter rescue mode.... and fsck the ubuntu disk.... following that... everything was good.

For the record, my Ubuntu was 8.04 - if I remember I tried booting from 8.04 and 8.10 with no luck.

Best of luck... in theory... assuming you have a way to get it.... any other distribution installation MIGHT be worth a go....

Malcolm
DoctorBeaver
Malcolm - thanks for that. I'll give it a try. Anything is worth a try because the PC is totally useless at the moment.
AftershockVibe
Sorry DoctorBeaver, I thought
Quote:
I tried to install again from scratch but although the CD drive is accessed I get exactly the same error.

meant that it failed after the install.

Normally, I'd suggest SuperGrubDisk:
http://www.supergrubdisk.org/

but their latest news post (10th April) doesn't fill me with confidence. Seems the new kernel setup isn't playing nice with Grub. There's a USB version though, should be easy enough to test and might be worth a go.
DoctorBeaver
AftershockVibe - I'll try the USB but I'm not hopeful.

Otherwise I think the only way I'm going to solve this problem will be to remove the hard drive, put it in another PC as an extra hard drive, wipe it completely, stick it back in the original PC and install again. I've got an ISO for a hard drive wiping program on CD but that didn't load either. Just gives me the same error 15. It seems to get the GRUB error before it even tries to do anything else. I can't even access the BIOS to change the boot disk before it happens.
DoctorBeaver
AftershockVibe - Just had a look at the instructions and I can't do it. The only version that doesn't need the BIOS changed has to be installed from a Linux PC. The only Linux PC I had is the 1 that went wrong. All the USB installs that can be done using Windows need a BIOS change to boot from the USB or flash drive.

Thanks for the suggestion anyway.
DoctorBeaver
Just had a thought; don't know whether it's sensible or not. I could open the case & disconnect the hard drive and try to boot from CD. Then, when I get the opening screen, re-connect the hard drive.

How much damage am I likely to do if I try that?
AftershockVibe
That shouldn't won't do any damage to your hardware but I don't think it will do you any good. The setup program will probably just not detect it after you reconnect.

I'm not sure why it's still reading from Grub... have you tried disabling all other boot devices other than the CDROM in the BIOS (and making sure they're in the right priority)? That might be worth investigating before trying to plug in hardware to a switch on computer.

Also, does GRUB give you any menu before it has Error 15? If it does you may have a way out.
DoctorBeaver
I can't get at the BIOS settings. The first thing it does is display "GRUB loading stage 1.5" then a couple of seconds later I get the error message. There's no menu, no BIOS option - nothing at all.
AftershockVibe
The BIOS has to load before Grub even if your monitor isn't quick enough to display it so you might have a way out here.

Hopefully if you hit DEL (or for some manufacturers it's F2) at startup you'll get to the BIOS setup. From there you can change the boot order and/or disable the HD.
DoctorBeaver
OK, I got at the BIOS (I'd been pressing the wrong key D'OH!) and set 1st boot drive to the CD/DVD RW but it still loads GRUB and hangs the same as before. It does that before the CD drive even starts up.

I couldn't see an option to boot from USB stick or memory card.

If I disable the hard drive from BIOS I can't install the OS on it.
SonLight
I would recommend booting a live cd, and verify that it is functional. From that, you shoulc be able to try accessing the hard drive, and see what's wrong. On the other hand, grub might be failing when it is trying to boot from the cd. If it won't boot either disk or cd, you could have a hardware problem. My Linux cd's contain a memory test option. That doesn't directly contribute to solving your problem, but if it runs that it will show that the cpu is working ok. You should also be able to type ESC and get to a grub prompt. If you can do that, you might try searching for files to find out what's wrong.

It is always good to have a rescue cd available. I recommend getting one, perhaps from www.sysresccd.org/ . It contains all the tools you need to repair most Linux problems, together with a lot of helpful information.
Daniel15
DoctorBeaver wrote:
OK, I got at the BIOS (I'd been pressing the wrong key D'OH!) and set 1st boot drive to the CD/DVD RW but it still loads GRUB and hangs the same as before. It does that before the CD drive even starts up.

Hmm, that is very weird. It should be booting from the CD fine. Try taking the hard drive out of the bootable devices (if it's possible) for now? I don't mean totally remove the hard drive, just remove it from the list of bootable devices. Some BIOSes allow this (ONLY boot from a certain device), whereas others don't.

If it's still not solved and you have another computer to use, you could always remove the hard drive, put it in the other computer, format it on there, then put it back. But this is very odd, you should be able to boot from CD even though the hard drive is not bootable.
DoctorBeaver
sonlight - the CD I'm trying to boot with is the 1 I installed Ubuntu with in the first place (8.04). It was when I tried to install 8.10 that we had the powercut.

Daniel - I've decided to remove the hard drive and put it in another PC. I'm going to wipe it & start from scratch with it.

It's strange because this has been the most reliable PC I've ever had (Sony Vaio). I've had it just over 5 years and never had any trouble with it at all apart from the usual Windows crap. It was because XP trashed out totally that I decided to switch it to Linux.
malcolmpreen
I'm guessing my previous post didn't help....

A couple more thoughts from here...

When ubuntu (8.04 in my case) is installed, I get two boot options for each kernel...

Ubuntu 8.04.2, kernel 2.6.24-23-generic
Ubuntu 8.04.2, kernel 2.6.24-23-generic (recovery mode)

It was the (recovery mode) one I used - which gave a lot more debug information when booting.... It ultimately failed to boot... but gave me more clues as to where the problem was.

I also had similar sounding problems when booting from install media (CD), which was ultimately tracked down to a faulty DVD Drive.... swapping the device out (assuming you have a spare) solved that problem in my case.

I'd definitely recommend trying various Live CDs as specified by others....

With regards to USB booting.... I think that requires a fairly modern BIOS.... how new is your machine?

Finally, before trashing the disk.... I'd add it as a second disk (via a caddy if needed) in another machine.... then you SHOULD be able to backup any vital data....

I keep a lot of old kit lying around "just in case".... as it often allows me to avoid disaster...

Good luck...

Malcolm
DoctorBeaver
Malcolm - thanks for that. The PC in question is a Sony Vaio I bought in 2005 so it's getting on a bit.

It has 2 CD/DVD drives - 1 is read only, the other is RW. I've tried the install CD in both so it's not a drive problem. The CD worked in another PC so it's not that either. It's definitely something that happened to the PC when the install got interrupted by the power cut.

I'm not going to trach the disk, just put it in another PC & wipe it completely. Then I can put it back in the Vaio & start from scratch.
Related topics
Blue screen before windows login.
I keep getting error e-mails
Need help booting from USB (Dell BIOS)
ubuntu
Please help. Major Problem with Linux on external Harddrive.
Trouble booting Ubuntu
My trouble with Ubuntu
Dual-Boot Windows and Ubuntu
Why my site is getting error ???
Laptop can't boot WinXP [solved]
Stranged thing ever happend on your pc
HOW TO: Format Hard Drive With Ubuntu BOOT DISK
RHEL 5 not booting.
Whos Got XP Still
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.