FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Getting very low frame rate





umeshtangnu
Hi
I just installed Serious Sam First Encounter and i am getting a very low frame rate ,around 14 fps,while playing.Even then menu's and end credits and very slow .
I m running
Winxp sp2 on Amd Phenom 9550 with 4Gb of ram and integrated ATI 3200 GPU with all latest drivers
umeshtangnu
i have disabled every effect in the game still i can get 20 to 25 fps
8166UY
Your graphic card is the problem. Get a HD4850 and you will play all games smoothly on high settings. Definitely worth it if you look at the other specs.
Diablosblizz
8166UY, there a few things to question before rushing out and buying a new graphics card, mainly is will it fit? There are many types of cards, PCI, AGP, and PCI-Express, and none will work in a different slot (simply won't fit). Before going to buy, do some research!

And yes, it is the reason that your games are slow. By the way, what's your processor speed?
umeshtangnu
8166UY wrote:
Your graphic card is the problem. Get a HD4850 and you will play all games smoothly on high settings. Definitely worth it if you look at the other specs.

bro the game was launched in 2001 so i dont think graphic card is a problem because it worked fine on my old system which has onboard VIA GPU
umeshtangnu
Diablosblizz wrote:
8166UY, there a few things to question before rushing out and buying a new graphics card, mainly is will it fit? There are many types of cards, PCI, AGP, and PCI-Express, and none will work in a different slot (simply won't fit). Before going to buy, do some research!

And yes, it is the reason that your games are slow. By the way, what's your processor speed?

Phenom X4 9550 2.2 GHz L2 4x 512 KB L3 2 MB
8166UY
Diablosblizz wrote:
8166UY, there a few things to question before rushing out and buying a new graphics card, mainly is will it fit? There are many types of cards, PCI, AGP, and PCI-Express, and none will work in a different slot (simply won't fit). Before going to buy, do some research!

And yes, it is the reason that your games are slow. By the way, what's your processor speed?


The Phenom X4 compatible boards all have PCI-E x16 Wink


If you sure that the old graphic card (which really sucks, even with old games) should play it, you might consider installing new drivers. But I doubt that there will be changes at all for that game.
umeshtangnu
8166UY wrote:
Diablosblizz wrote:
8166UY, there a few things to question before rushing out and buying a new graphics card, mainly is will it fit? There are many types of cards, PCI, AGP, and PCI-Express, and none will work in a different slot (simply won't fit). Before going to buy, do some research!

And yes, it is the reason that your games are slow. By the way, what's your processor speed?


The Phenom X4 compatible boards all have PCI-E x16 Wink


If you sure that the old graphic card (which really sucks, even with old games) should play it, you might consider installing new drivers. But I doubt that there will be changes at all for that game.

ya it ran well on both the VIA onboard and the FX5200
i have updated the Catalyst drivers
8166UY
Really strange case. You could also try to see if the GPU/PC isn't cooled well.
umeshtangnu
8166UY wrote:
Really strange case. You could also try to see if the GPU/PC isn't cooled well.

will check that out
btw i disabled hardware rendering got a boost in FPS
Diablosblizz
Try changing the anti-aliasing in the ATI control centre to "Use application settings" then just change the games options to disable it. Basically, go through the control centre and change everything you can to "use application settings." If you want looks over performance, you'll have to deal with the lag. Personally, I don't care what it looks like, as long as it's a good game.
David_Pardy
See if you can borrow a card.

If you're in Australia I'd be willing to sell you a PCI-e 512mb ASUS Geforce 8600GT for $80 Wink
8166UY
I could buy a new one for that. Razz But borrowing a graphic card to test it out is a pretty good idea.
David_Pardy
The card cost me $130 new and that was discounted! Australia's pricing for computer parts sucks.

Even when the exchange rate was nearly matching the US$ (it's fallen again) we were still paying 2 to 5 times the price for software. Not sure about hardware but it's really no different Sad.
umeshtangnu
Diablosblizz wrote:
Try changing the anti-aliasing in the ATI control centre to "Use application settings" then just change the games options to disable it. Basically, go through the control centre and change everything you can to "use application settings." If you want looks over performance, you'll have to deal with the lag. Personally, I don't care what it looks like, as long as it's a good game.

did as u said but still no improvement
The game was released in 2001 there should not be any lag and my system does run NFS UnderCover giving decent performance dont know why this games does not run properly
Related topics
im worried my points getting low. [solved]
Shadow of The Colossus - video game
What do you think of Supreme Commander? and possibly others?
5 Best Open Source Remote Desktop Software 4 linux
PSP GTA Liberty City Stories
Counter strike lags piss me off...
Irritating Gaming Trends
Tomb Rider: Legend - My short review.
Help a n00b obtain a domain?
Titan Quest
What Digital Camera do you have ?
(juego) que tenes en tu Ctrl + V ?
think its nice?
WRT54GS Extra-Slow Download Speeds
Reply to topic    Frihost Forum Index -> Sports and Entertainment -> Games

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.