FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Installing phpBB on a frihost account...





gilwe
OK so I have my domain set up on my account, and get the "DirectAdmin" logo page once referring to it.

I copied the phpBB3 directory completely into the public_html directory,
but when I refer to the install/index.php under public_html, from the web address,
nothing loads.

Actually, if I place an index.php file in the main directory (near the default index.html file)
and try to run it, it won't do anything, just give a "The requested URL /index.php was not found on this server. " error.

Does anyone know how can this get solved ?

Thanks !
truespeed
Did you set the permission right during install? by permissions i mean did you chmod the folders correctly?
gilwe
I haven't set anything, only copied the phpBB directory from my local environment to the server via FTP...

Any directions of how this can be done please ?
neji
Did you accidently copied the phpBB3 folder containing the files in a folder?

-> Folder 'phpBB3' -> Folder 'phpBB3' -> Folders + files

=> url.frih.net/phpBB3/phpBB3/install/index.php
gilwe
Nope.

I've placed a phpBB3 with all related files under it, while phpBB3 folder is directly under public_html...

So

=> url.frih.net/public_html/phpBB3/install/index.php

which lays near

=> url.frih.net/public_html/cgi-bin

Thanks !

Wink
truespeed
Try chmoding the install folder to 777. during the install process it should tell you which folders need to have their permissions changed.

If you don't know how to chmod,right click on the folder ,go down to file permissions and change to what ever number you want.

Maybe you could even delete the files and start the install process again,also dont forget to create another database,unless you know how to go into phpmyadmin and drop all the files.
gilwe
Somehow I now get the following error while running index:

Parse error: syntax error, unexpected $end in /usr/home/gilwe/domains/gilwe.frih.org/public_html/phpBB3/includes/functions.php on line 1870

Thanks !
truespeed
I would just delete all the files and start again.
gilwe
Thanks, will try that and post results soon ! Wink
gilwe
Hi again,

Well, the database and phpbb forum are set up ok now,
and I can reach the phpbb admin page by clicking:
http://gilwe.frih.org/phpBB3/adm/index.php

I also referred a dot com domain to your DNS and once I click the address
I reach the "DirectAdmin" page.

How can I make phpbb load under the dot com domain ? i.e

http://<domainname.com>/phpBB3/adm/index.php

Thanks!
Related topics
Posting Guidelines / Guidelines to Make Quality Posts
cpanel q: Doesn't seem to be a firewall issue
While installing phpBB...
FRIHOST account
Can I copy/upload entire directories in a frihost account
Issue installing phpBB forum
phpBB - Installation Tutorial
Multiple blogs in one Frihost account.
phpbb2 with frihost problem
A question about php on my frihost account
Need help in installing phpBB
Installing PHPBB
a lot of mail are sent from my frihost account.
a lot of mail are sent from my frihost account.
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.