FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Boot loader





Chris65536
No idea where to stick this... Confused

Anywho: the default bootloader that comes with Ubuntu seems to be doing something odd. On a dual-boot PC, I have Ubuntu and Vista.

The thing is that I have 3 copies of all the boot options of Ubuntu (not 3 options: 3 copies of Ubuntu and Recovery Mode, or whatever it's called), and 2 listings of Vista.

So... ideas to fix? Razz

And I'm sorry that I can't tell you what boot program it's called. I don't know. I'm a Linux noob: I only found out about sudo last week!
RiCtee
It's called GRUB. You can easily edit the list by using the command "sudo gedit /boot/grub/menu.lst". Here you can change all the options. It should be self-explanatory and the comments are quite simple to understand. For example my Ubuntu and Windows XP dual boot:
Quote:
## ## End Default Options ##

title Ubuntu 8.10, kernel 2.6.27-7-generic
uuid 1f15ee53-d976-43cd-97e2-f8ec4a2a1976
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=1f15ee53-d976-43cd-97e2-f8ec4a2a1976 ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
quiet

title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode)
uuid 1f15ee53-d976-43cd-97e2-f8ec4a2a1976
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=1f15ee53-d976-43cd-97e2-f8ec4a2a1976 ro single
initrd /boot/initrd.img-2.6.27-7-generic

title Ubuntu 8.10, memtest86+
uuid 1f15ee53-d976-43cd-97e2-f8ec4a2a1976
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1

You can remove those entries by simply deleting those lines.
Another easier method (if you prefer an interface and clicking), just install the Start-Up Manager with "sudo apt-get install startupmanager". And then run it with Alt-F2 -> startupmanager.
Fire Boar
Sounds like you upgraded your kernel twice (new kernels appear as dependencies of linux-generic whenever they're released), and the grub auto-configurer doesn't remove kernels from the list, it adds them. So if you keep installing more and more kernels, it can eventually get out of hand.

There's a couple of things you can do:

Option 1: Don't update any of the kernel packages
The simplest option. Does just what it says on the tin. Simply put, during an update don't update linux-(anything). You can also use the following to keep it from installing new versions of the kernel echo [package] hold | dpkg --set-selections, replacing [package] with each linux- package you have.

Option 2: Remove linux-generic
This is potentially dangerous with apt's dependency resolving, and I wouldn't recommend it but you CAN remove the linux-generic package along with all the linux-[something]-generic packages you have that don't list a version number. They're just meta-packages. Be careful though - it may try and remove the kernel itself which is Really Bad.

Option 3: Run apt-get autoremove

Do NOT use this in combination with option 2, because it will DEFINITELY try to remove your kernel. However, if you take my advice and don't use option 2, this should be fine since it removes any packages which no longer meet dependencies and were not deliberately installed by you. In other words, it'll clean up all the older kernels you have lying around leaving only the latest one.


Whatever you choose to do, you should definitely edit /boot/grub/menu.lst as suggested by RiCtee and delete the un-needed bootup options.
albuferque
Just edit /etc/grub.conf

You could also remove the kernels you don't want from /boot
Go into synaptic. and search "linux-image". select all installed ones but the latest. It maybe linux-image-2.6.X-Y. and the press apply. (Installed packages' checkboxes are gray)

o_man
albuferque wrote:
Just edit /etc/grub.conf

You could also remove the kernels you don't want from /boot
Go into synaptic. and search "linux-image". select all installed ones but the latest. It maybe linux-image-2.6.X-Y. and the press apply. (Installed packages' checkboxes are gray)



This solution is the easiest for a n00b
Fire Boar
albuferque wrote:
Just edit /etc/grub.conf


This file doesn't exist in Ubuntu, it's /boot/grub/menu.lst you're after.
Chris65536
Ok, I'll try that.

What strikes me as odd is that Vista gets listed twice as well :S And it's been that way since I installed Ubuntu...

sudo gedit /boot/grub/menu.lst. Got it.
Fire Boar
Chris65536 wrote:
Ok, I'll try that.

What strikes me as odd is that Vista gets listed twice as well :S And it's been that way since I installed Ubuntu...

sudo gedit /boot/grub/menu.lst. Got it.


Well, perhaps you've got a recovery partition or something, and it was recognizing that as an OS. Vista's strange. Anyway, you can just delete the spare from inside /boot/grub/menu.lst. Good luck.
elyo-luk
You can use LILO: http://en.wikipedia.org/wiki/LILO
Fire Boar
elyo-luk wrote:
You can use LILO: http://en.wikipedia.org/wiki/LILO


I wouldn't. LILO is a very old program, and lacks some of the features that GRUB offers. Also, it's a lot more effort to install and maintain, and is generally a lot more trouble than it's worth when you already have GRUB. It won't fix any of the problems the OP is having either.
elyo-luk
Fire Boar wrote:
elyo-luk wrote:
You can use LILO: http://en.wikipedia.org/wiki/LILO


I wouldn't. LILO is a very old program, and lacks some of the features that GRUB offers. Also, it's a lot more effort to install and maintain, and is generally a lot more trouble than it's worth when you already have GRUB. It won't fix any of the problems the OP is having either.

Yes, i know, but is a option to choose
sheedatali
Quote:
Yes, i know, but is a option to choose


This is what I hate when guys just respond to a thread because they just feel like saying anything, even if it does not add any value. Clearly the OP is not an expert in using Linux, and you are suggesting him to use another boot loader, which not only does not make any sense, it might mess up his installation. Previous posters already gave enough information to solve the issue with good answers, I guess what I am trying to say is that you should consider what the target audience is, and would it help them or not.

/2p
Related topics
Linux & Windows
Creating a new Operating System
Tutorials-How To Install Winxp And Linux To The Same Compute
Boot disk problem.
Laptop and Network problems.. help please
Question about setting up dual boot-windows xp and mandriva
Booting Linux using Windows boot loader
grub boot loader gone
Grub Problem!
SUSE GRUB kills my MBR to boot to XP, W2003 & SUSE
Linux Boot problem
Strange (lack of) Boot behavior
switching between GRUB and windows boot manager
How can I restore my XP boot loader ?
Reply to topic    Frihost Forum Index -> Computers -> Operating Systems

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.