FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Applets possible...?





wombatrpgs
I don't seem to be able to put applets on my website. I'm almost positive this code is formatted correctly, checked a hundred places... The wombattle.jar does exist, and in it the MainScreen.class as well. Does Server 3 support applets or is there a problem with my code?

The HTML page:
Code:
<html>
<body>
<p>
<applet
code= "MainScreen.class"
width= "320"
height= "240"
archive="wombattle.jar"
codebase= "http://www.wombatrpgs.frih.net/"
></applet>
</p>
</body>
</html>


...and the error generated...

Code:
load: class MainScreen.class not found.
java.lang.ClassNotFoundException: MainScreen.class
<SNIP>


And the code pretty much works on my other page.
http://users.wpi.edu/~aking/view.html
Bondings
Maybe the files are not in the correct directory? I don't think this has anything to do with the server configuration since only the files are needed.
wombatrpgs
I wouldn't think so either, but I tried changing around a lot of the HTML, taking the .class files out of the jar, and most other common fixes. When I tried transferring to that other page it worked fine. All I did was change the codebase variable, which I'm pretty sure is set correctly in this case. And the files exist...
http://www.wombatrpgs.frih.net/wombattle.jar
http://www.wombatrpgs.frih.net/view.html
Bondings
wombatrpgs wrote:
I wouldn't think so either, but I tried changing around a lot of the HTML, taking the .class files out of the jar, and most other common fixes. When I tried transferring to that other page it worked fine. All I did was change the codebase variable, which I'm pretty sure is set correctly in this case. And the files exist...
http://www.wombatrpgs.frih.net/wombattle.jar
http://www.wombatrpgs.frih.net/view.html

The http://www.wombatrpgs.frih.net/view.html shows the same grey box as the http://users.wpi.edu/~aking/view.html one for me. That's all I get though. They seem to be loading fine but doing nothing.
wombatrpgs
Weird... I get one to load and function properly, and the oteher gives me a ClassNotFoundException. Though if it's not consistent results, then it's probably not the server and I'll keep checking for errors I made...
Related topics
Tutorials
Russian forum, if it possible?
Is it possible to...
Is it possible to add/manage my email forwarders with PHP?
PHP & Chat
Is it possible, can you build your own laptop from scratch ?
[RESOLVED] Is it possible to put up a music page
Would it be possible...?
DSP Tutorial with Java Applets
How to become a millionaire on the internet?
Programming links, info, and tutorials
Applets
swf to fla
is it possible to use my own domain
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.